[CentOS-devel] XFS module ... big troubles

Gernot Stocker gernot.stocker at tugraz.at
Fri Apr 27 15:12:50 UTC 2007


On Friday 27 April 2007, Johnny Hughes wrote:
> OK ... I can confirm that I copied a large file (650mb ISO file) from
> ext3 to XFS partition ... and the MD5 sums were indeed different

Bad for the module but good for my system ;-) I would suggest to remove 
the i686 module from the devs-testing site until the problem is solved. We
have lost files, which we could restore somehow. But it shouldn't happen to 
other people as well.
 
> (This is on an i686 kernel, with the standard module loaded)

My system is also a i686 system. In the other mail I meant with i386 the 
i386-family.
 
> However, I did not have any errors in:
> 
> "xfs_logprint /dev/hda3"
> 
> so this is quite strange.

I think that the errors in xfs_logprint are just a matter of time and transferred files. 
I'm synching a directory tree (using rsync) of about 2000 files with different size 
and I'm checking it with a "find ./ -type f -exec md5sum {} \; | sort" against the 
original tree.

> I have the test suite compiled now and I will kick off this test in a
> little while.

Good hunting!
Gernot
-------------- next part --------------
A non-text attachment was scrubbed...
Name: not available
Type: application/pgp-signature
Size: 189 bytes
Desc: not available
Url : http://lists.centos.org/pipermail/centos-devel/attachments/20070427/d624a3c0/attachment.bin


More information about the CentOS-devel mailing list