[CentOS-devel] updated yum packages are now available in c5-testing

James Antill james at fedoraproject.org
Mon Dec 22 20:59:28 UTC 2008


On Mon, 2008-12-22 at 12:29 -0800, Akemi Yagi wrote:
> On Fri, Dec 12, 2008 at 4:56 PM, Karanbir Singh <mail-lists at karan.org> wrote:
> > The following packages have been updated in the testing repo :
> > ./5/testing/SRPMS/yum-utils-1.1.16-13.el5.centos.src.rpm
> > ./5/testing/SRPMS/yum-3.2.19-18.el5.centos.src.rpm
> 
> > test these on non-production machines only for now. And all feedback is
> > appreciated.
> 
> yum-3.2.19-18 produces the following errors if run with the
> "--enablerepo=atrpms" option.

 It goes back to working again, if you use the older yum version? Does
it then fail again if you re-use the newer yum?

[...]
>   File "/usr/lib/python2.4/site-packages/yum/sqlitesack.py", line 470,
> in _sql_pkgKey2po
>     pkg = self._packageByKey(repo, ob['pkgKey'])
>   File "/usr/lib/python2.4/site-packages/yum/sqlitesack.py", line 413,
> in _packageByKey
>     po = self.pc(repo, cur.fetchone())
>   File "/usr/lib/python2.4/site-packages/yum/sqlitesack.py", line 68,
> in __init__
>     self._read_db_obj(db_obj)
>   File "/usr/lib/python2.4/site-packages/yum/sqlitesack.py", line 94,
> in _read_db_obj
>     setattr(self, item, _share_data(db_obj[item]))
> TypeError: unsubscriptable object

 This is more understandable upstream by:

http://yum.baseurl.org/gitweb?p=yum.git;a=commitdiff;h=3120676a73219b018d317d8adaac0d858d751a3b;hp=54bd2c6eebf6be6b2596e25538bff6b35e34c443

...which gives a "nice" message. There is also a change to
yum-metadata-parser, which should work around the problem in atrpms.
 The short term. fixes are:

1. Don't use atrpms.

2. Use "yum clean metadata"

-- 
James Antill <james at fedoraproject.org>
Fedora


More information about the CentOS-devel mailing list