[CentOS-devel] updated yum packages are now available in c5-testing

James Antill james at fedoraproject.org
Tue Dec 23 07:24:08 UTC 2008


On Tue, 2008-12-23 at 08:12 +0200, Axel Thimm wrote:
> On Mon, Dec 22, 2008 at 05:48:22PM -0500, James Antill wrote:
> > >  If it's something I can fix on my end,
> > > I'd gladly do so, but I'm just using plain createrepo (and this seems
> > > to work with the yum version in question with other distros).
> > 
> >  Pass -d to create repo. and it'll work (and be faster).
> 
> OK, which version of createrepo should be used (distribution range is
> EL3-5, F8-10)? Currently I use 0.4.9, but there is even 0.9.6
> available.

 Any version 0.4.9 or later should be fine (I think even 0.4.4 will
work, but I haven't checked).
 Anything "recent" will also add group_gz which the yum in testing
can/will use, but that's just a bonus if it's not a problem to use that.

> Or does it not matter wrt the outcome?

 In theory the DB is versioned, so you can have createrepo make a
version that yum doesn't like ... I don't think this has ever been
possible though, and it's very likely we won't use this feature going
forward due to the downsides (the client has to download the .sqlite
file to work out it can't use it -- and it'd currently "break"
mdpolicy).

-- 
James Antill <james at fedoraproject.org>
Fedora


More information about the CentOS-devel mailing list