[CentOS-devel] perl and perl::IO conflict

Ralph Angenendt ra+centos at br-online.de
Sun Jul 13 09:51:50 UTC 2008


Hugo van der Kooij wrote:
> BTW the conflict shows up as:
>
> ~        file /usr/lib/perl5/5.8.8/i386-linux-thread-multi/IO.pm from
> install of perl-IO-1.2301-1 conflicts with file from package
> perl-5.8.8-10.el5_2.3

From CentOS 5 on this could be a non-issue, if external perl packages
would put their stuff into /usr/lib/perl5/site_perl which comes before
/usr/lib/perl5/5.8.8 in @INC. That would leave you with the the man page
problem, though and I don't know of a workaround against that.

But: The above doesn't work on 4 and 3, as those have site_perl much
further down in @INC so you cannot override packages which are included
in the perl package.

Ralph
-------------- next part --------------
A non-text attachment was scrubbed...
Name: not available
Type: application/pgp-signature
Size: 194 bytes
Desc: not available
Url : http://lists.centos.org/pipermail/centos-devel/attachments/20080713/6c71f267/attachment.bin


More information about the CentOS-devel mailing list