[CentOS-devel] apr-devel and httpd-devel packaging problem

Ralph Angenendt ra+centos at br-online.de
Sun Jun 29 21:57:16 UTC 2008


Morning,

we seem to have a packaging problem with httpd-devel.x86_64 and
apr-devel.x86_64.

If you install httpd-devel on an x86_64 machine, apr-devel is required
by this package.

It then goes on to install apr-devel - but the i386 version.

Because of this apxs dies with:

cannot open /httpd/build/config_vars.mk: No such file or directory at
/usr/sbin/apxs line 201.

See <http://bugs.centos.org/view.php?id=2934>

apr-devel.x86_64 does not provide apr-devel in a 64 bit version *and*
httpd-devel does not require apr-devel in a 64bit version.

This way only the i386 version gets installed, while pkg-config on a
64bit machine will look in /usr/lib64/pkgconfig for the apr-1.pc
package.

Same goes for the 64bit apr-util-devel package.

Can someone look into the RHEL 5.2 packages to see if that is an
upstream problem?

Strange thing: The Requires and Provides are the same in 5.1 - but there
the x86_64 versions of apr-devel and apr-util-devel get installed when
you install httpd-devel.x86_64 - and not the i386 versions.

Ralph
-------------- next part --------------
A non-text attachment was scrubbed...
Name: not available
Type: application/pgp-signature
Size: 194 bytes
Desc: not available
Url : http://lists.centos.org/pipermail/centos-devel/attachments/20080629/0b96996c/attachment.bin


More information about the CentOS-devel mailing list