[CentOS-devel] rubygems rpm spec file

Matt Rose mrose at n-able.com
Tue Nov 18 17:53:12 UTC 2008


Ralph Angenendt wrote:
> Matt Rose wrote:
>   
>> requires: ruby >= 1.8.5, ruby-libs >= 1.8.5
>>     
>
> Are you sure about that? I only have
>
> Requires: ruby(abi) = 1.8
>
> in my spec (which is for 1.1.1 though)
>
>   
I don't think it actually requires ruby-libs, but the way I figure, 
they're going to need the ruby stdlib if they're going to actually 
install most gems.  Better to set up the expectation in advance, IMO.

>> Source0: %{name}-%{version}.tgz
>> License: GPL
>>     
>
> I think naming both licenses is correct here:
>
> License: Ruby License/GPL
>
>   
>> BuildPreReq: ruby >= 1.8.5, ruby-libs >= 1.8.5
>>     
>
> Hmmm. Why PreReq?
>
> I have BuildRequires: ruby, ruby-irb, ruby-rdoc in my spec.
>
>   
Because I forgot the syntax for BuildRequires
>> %description
>> Ruby Gems
>>     
>
> RubyGems is the Ruby standard for publishing and managing third party
> libraries.
>
> Yours is a tad short :)
>
>   
>> cd $RPM_BUILD_ROOT
>> rm -rf %{buildroot}
>>     
>
> Hmmm. Either or, I think. Not both in one spec file :)
>   

good idea.
> I also have a wad of rubygems which are packaged and should be published
> somewhere (like a complete rails 2.1 environment, mod_passenger and other
> stuff).
>
> Cheers,
>
> Ralph
>   
we could put them up on github or I could host a publically available 
subver repo for ruby gem rpms, or something.  It would be nice to have a 
central repo for exactly this kind of stuff.   I wonder how hard it 
would be to do a gem2rpm script, like perl has with cpan2rpm.

Matt
-------------- next part --------------
An HTML attachment was scrubbed...
URL: http://lists.centos.org/pipermail/centos-devel/attachments/20081118/b9ca15b4/attachment.htm


More information about the CentOS-devel mailing list