[CentOS-devel] Building latest kmods for latest kernel automatically

Akemi Yagi amyagi at gmail.com
Tue Nov 18 22:28:13 UTC 2008


On Tue, Nov 18, 2008 at 2:20 PM, Fabian Arrotin
<fabian.arrotin at arrfab.net> wrote:
> Akemi Yagi wrote:
>>
>> On Tue, Nov 18, 2008 at 1:55 PM, Fabian Arrotin
>
> <snip>

Ah, your post crossed mine :-D

> Yes, my bad .. i didn't notice that actual kmod-drbd82-8.2.6-2 already used
> the weak-modules scripts ...
> I think the wiki has to be updated now to say "yum install kmod-drbd82"and
> not "yum install kmod-drbd82-`uname -r`"

It needs to be corrected, yes.

> On the other hand it's true that having old kmod (with specific kver in the
> name) in the same repository tends to confuse people : that's why i reacted
> on the first question because there was no 'actual' kmod in the repo .. so i
> guess that all older kmods not using /sbin/weak-updates can be removed from
> the repo

I agree.  Older files must go.

> Are all the provided kmod rpms already using the weak-modules scripts ?

I believe Johnny has done them all but this has to be re-checked with
him (or by testing them).

Akemi


More information about the CentOS-devel mailing list