[CentOS-devel] debuginfo repo and debuginfo-install

Dan Bolser dan.bolser at gmail.com
Fri Nov 21 19:26:45 UTC 2008


2008/11/21 Jeff Johnson <n3npq at mac.com>:
> Run rpm --verify on the pango -debuginfo package.
> If differences are reported, erase and re-install.
> If no differences, then the pango -debuginfo package
> was not produced correctly. Note that the CRC check
> is from gdb & ELF, not from package management.

rpm --verify pango pango-debuginfo

no output

Does that show that the pango -debuginfo package was not produced
correctly? Who should I bug?

Cheers,
Dan.

>
> hth
>
> 73 de Jeff
>
> On Nov 21, 2008, at 1:45 PM, Dan Bolser wrote:
>
>> Hi, I used
>>
>> sudo debuginfo-install firefox
>>
>>
>> To get the debugging packages necessary to run firefox from within gdb
>> and get some meaningful stack trace output - see
>> http://bugs.centos.org/view.php?id=3258
>>
>>
>> To make this work properly, I installed the 'debuginfo-repo' like this:
>>
>> more /etc/yum.repos.d/debuggery.repo
>> [debuggery]
>> name=CentOS-$releasever - DebugInfo
>> baseurl=http://debuginfo.centos.org/$releasever/$basearch/
>> priority=1
>>
>>
>> However, it seems there is a problem with the pango package in that
>> repo, because when I fire up firefox within gdb I get the following
>> warnings:
>>
>> (gdb) run -P "Local Disk"
>> Starting program: /usr/lib/firefox-3.0.4/firefox -P "Local Disk"
>> (no debugging symbols found)
>> [Thread debugging using libthread_db enabled]
>> [New Thread -1208387888 (LWP 7595)]
>> warning: the debug information found in
>> "/usr/lib/debug//usr/lib/libpangocairo-1.0.so.0.1400.9.debug" does not
>> match "/usr/lib/libpangocairo-1.0.so.0" (CRC mismatch).
>>
>> warning: the debug information found in
>> "/usr/lib/debug//usr/lib/libpangoft2-1.0.so.0.1400.9.debug" does not
>> match "/usr/lib/libpangoft2-1.0.so.0" (CRC mismatch).
>>
>> warning: the debug information found in
>> "/usr/lib/debug//usr/lib/libpango-1.0.so.0.1400.9.debug" does not
>> match "/usr/lib/libpango-1.0.so.0" (CRC mismatch).
>>
>> [New Thread -1210643568 (LWP 7598)]
>> [New Thread -1221133424 (LWP 7599)]
>> FoxyProxy settingsDir = /local/Scratch/.mozilla/firefox/fcftz9c3.default
>> [New Thread -1231643760 (LWP 7600)]
>> [New Thread -1243612272 (LWP 7601)]
>> [Thread -1243612272 (LWP 7601) exited]
>> [New Thread -1254102128 (LWP 7602)]
>> [Thread -1254102128 (LWP 7602) exited]
>> [New Thread -1254102128 (LWP 7603)]
>> [New Thread -1243612272 (LWP 7604)]
>> [New Thread -1265009776 (LWP 7605)]
>> warning: the debug information found in
>> "/usr/lib/debug//usr/lib/pango/1.5.0/modules/pango-basic-fc.so.debug"
>> does not match "/usr/lib/pango/1.5.0/modules/pango-basic-fc.so" (CRC
>> mismatch).
>>
>> [Thread -1265009776 (LWP 7605) exited]
>> [New Thread -1265009776 (LWP 7606)]
>> [New Thread -1342178416 (LWP 7607)]
>> ...
>>
>>
>> This seems strange, because looking at the output of this:
>>
>> [dbolser at cricket ~]$ yum list installed | grep pango
>> pango.i386                               1.14.9-3.el5.centos    installed
>> pango-debuginfo.i386                     1.14.9-3.el5.centos    installed
>> pango-devel.i386                         1.14.9-3.el5.centos    installed
>>
>>
>> Seems to suggest that all the package versions match.
>>
>> Also, for the sake of yum, how come the debuginfo packages do not
>> depend on their version matched package counterpart?
>>
>>
>> Thanks for any help, and sorry if this is the wrong place to post such
>> a message - please just let me know where I should have sent the
>> email.
>>
>>
>> All the best,
>>
>> Dan.
>>
>>
>> --
>> http://network.nature.com/profile/dan
>> _______________________________________________
>> CentOS-devel mailing list
>> CentOS-devel at centos.org
>> http://lists.centos.org/mailman/listinfo/centos-devel
>
> _______________________________________________
> CentOS-devel mailing list
> CentOS-devel at centos.org
> http://lists.centos.org/mailman/listinfo/centos-devel
>



-- 
http://network.nature.com/profile/dan


More information about the CentOS-devel mailing list