[CentOS-devel] Centos 5.3 dependency check?

Markus Falb markus.falb at fasel.at
Sun Apr 5 12:41:31 UTC 2009


Hugo van der Kooij wrote:

> It seems that a package is now added to perl in Centos 5.3 that was not
> there before.
> 
> So a dependency on perl-MIME-Base64 will fail because that package now
> seems to colide with perl itself. (SIGHHHH)
> 
> How can I change my spec file to list the requirement only for
> Centos/RHEL 5.x where x < 3?

hmm. strange enough:
# cat /etc/redhat-release 
CentOS release 5.2 (Final)
# rpm -q --whatprovides 'perl(MIME::Base64)'
perl-5.8.8-15.el5_2.1

maybe the conditional requirement is not necessary. try a:
Require: perl(MIME::Base64)

-- 
best regards,
markus



More information about the CentOS-devel mailing list