[CentOS-devel] no drbd after update to 5.3

Akemi Yagi amyagi at gmail.com
Mon Apr 13 23:08:28 UTC 2009


On Mon, Apr 13, 2009 at 2:09 PM, Jerry Amundson <jamundso at gmail.com> wrote:
> On Mon, Apr 13, 2009 at 4:05 PM, Akemi Yagi <amyagi at gmail.com> wrote:

>>> [root at xenb ~]# rpm -qa kernel\* | sort
>>> kernel-headers-2.6.18-128.1.6.el5
>>> kernel-xen-2.6.18-128.1.6.el5
>>> kernel-xen-2.6.18-92.1.10.el5
>>> kernel-xen-2.6.18-92.1.22.el5
>>> [root at xenb ~]# rpm -qa \*drbd\* | sort
>>> drbd82-8.2.6-1.el5.centos
>>> kmod-drbd82-xen-8.2.6-1.2.6.18_92.1.10.el5
>>> kmod-drbd82-xen-8.2.6-2
>>> [root at xenb ~]# ls -l `find /lib/modules -name drbd.ko`
>>> lrwxrwxrwx 1 root root      54 Apr 13 13:57
>>> /lib/modules/2.6.18-128.1.6.el5xen/weak-updates/drbd82/drbd.ko ->
>>> /lib/modules/2.6.18-92.1.6.el5xen/extra/drbd82/drbd.ko
>>
>> This is not right.  kmod-drbd82-xen-8.2.6-2 is supposed to install:
>>
>> /lib/modules/2.6.18-92.1.13.el5xen/extra/drbd82/drbd.ko
>>
>> and the symlink should look like:
>>
>> /lib/modules/2.6.18-128.1.6.el5xen/weak-updates/drbd82/drbd.ko ->
>> /lib/modules/2.6.18-92.1.13.el5xen/extra/drbd82/drbd.ko
>>
>> Could you show us the output from:
>>
>> rpm -ql kmod-drbd82-xen
>>
>> rpm -q --scripts kmod-drbd82-xen
>
> [root at xenb ~]# rpm -ql kmod-drbd82-xen
> /lib/modules/2.6.18-92.1.10.el5xen/extra/drbd82/drbd.ko
> /lib/modules/2.6.18-92.1.13.el5xen
> /lib/modules/2.6.18-92.1.13.el5xen/extra
> /lib/modules/2.6.18-92.1.13.el5xen/extra/drbd82
> /lib/modules/2.6.18-92.1.13.el5xen/extra/drbd82/drbd.ko

I suppose, at some point in time, you had
kmod-drbd-xen-8.0.12-1.2.6.18_92.1.6.el5 which installed
/lib/modules/2.6.18-92.1.6.el5xen/extra/drbd82/drbd.ko. [expected
behavior]

When kmod-drbd82-xen-8.2.6-2 was installed later on, it installed
/lib/modules/2.6.18-92.1.13.el5xen/extra/drbd82/drbd.ko and created
symlinks through the action of /sbin/weak-modules.  Kernels that
existed at that moment now point to the drbd.ko in
/lib/modules/2.6.18-92.1.13.el5xen. [expected behavior]

When the kernel was updated to -128 (upon 5.3 update), weak-modules
was supposed to do the same (create a symlink to
2.6.18-92.1.13.el5xen).  But instead, it made a link to
2.6.18-92.1.6.el5xen.  This is the part I don't understand. [???]

Can someone figure out what is going on here?  Fabian?

Akemi


More information about the CentOS-devel mailing list