[CentOS-devel] there's something happened between kernel 2.6.28-128.1.1 and 2.6.18-128.1.6 compilation

Jeff Johnson n3npq at mac.com
Mon Apr 20 13:17:44 UTC 2009


On Apr 20, 2009, at 7:49 AM, Farkas Levente wrote:

> Karanbir Singh wrote:
>> Farkas Levente wrote:
>>> run this two command on centos's src.rpm:
>>> --------------------------------------
>>> rpm -qp --requires kernel-2.6.18-128.1.1.el5.src.rpm | grep unifdef
>>> rpm -qp --requires kernel-2.6.18-128.1.6.el5.src.rpm | grep unifdef
>>
>> here is what I get on the src.rpm at this end:
>> rpm -qp --requires kernel-2.6.18-128.1.6.el5.src.rpm | grep unifdef
>> unifdef
>>
>> let me investigate what the problem might be
>
> ok. i recheck it on centos-5.3 and still not true.
> did you test the src.rpm on the mirror sites?

At the link you reported
	https://bugzilla.redhat.com/show_bug.cgi?id=496464
the root cause of the problem is likely described
     I'd suspect something changed in the build process that caused  
with_headers to be undefined.
Have you tried to confirm that analysis?
There's noone saying that you're not seeing what you're seeing,
a kernel package without
     Requires: unifdef

73 de Jeff


More information about the CentOS-devel mailing list