[CentOS-devel] kdebindings-3.5.4-6.el5.src.rpm seems to be wrong

Jeff Johnson n3npq at mac.com
Wed Apr 22 02:29:48 UTC 2009


On Apr 21, 2009, at 9:10 PM, Jeff Johnson wrote:

>
> On Apr 21, 2009, at 6:44 PM, Farkas Levente wrote:
>>
>> then you'd have to send to the upstream rpm, but i'd be more happy to
>> fix #495689 and be able to use 5.3's rpm with mock-0.9 instead of
>> 5.2's
>> rpm:-)
>>

FYI: re #495689

 >> 1. rpm/yum (on the buildhost) not respecting pam's
 >> Requires(post): coreutils

The only circumstance under which a dependency is ignored by rpm
(yum does things differently) is when a dependency loop is involved.
With pam <-> initscripts, I'm not surprised that there are dependency  
loops.

 >> 2. pam's scriptlets unsafe and not ending with ||:
 >> 3. rpm/yum (on the buildhost) exiting with error-code on a scriptlet
Ignoring error codes is hardly a proper "fix".

The 1st step to resolving the issue is identifying the dependency loops
and the package ordering that was attempted by mock.

If mock and yum cannot provide the necessary info re whether
loops were present (or not) and what order the packages were
installed, well, rpm can if you patch the error message
in lib/depends.c rpmtsOrder() to change the diagnostic
message from RPMLOG_DEBUG to RPMLOG_WARNING.

Yes you will have to rebuild rpm to do that.
hth
73 de Jeff





More information about the CentOS-devel mailing list