[CentOS-devel] ELrepo video4linux on CentOS 5 2.6.18-128.4.1.el5xen - can't work !

Philippe philippe at lefacteur.fr
Sat Aug 8 00:42:09 UTC 2009


hello,

I'm running on centos5.3 xen

    [root at aberlour]# uname -a
    Linux aberlour 2.6.18-128.4.1.el5xen #1 SMP Tue Aug 4 21:33:24 EDT 
2009 i686 athlon i386 GNU/Linux


I installed elrepo to use my webcam(S).

the package kmod-video4linux-xen is really installed:

	[root at aberlour]# rpm -qa|grep video
	kmod-video4linux-xen-0.0-5.20090615.el5.elrepo

but when I "modprobe gspca_main" I've got.

	[root at aberlour]# modprobe gspca_main
	FATAL: Module gspca_main not found.

the problem is that the module is located in the wrong directory

	[root at aberlour]# locate gspca_main.ko
	/lib/modules/2.6.18-128.el5xen/extra/video4linux/gspca_main.ko

instead of: 
	/lib/modules/2.6.18-128_.4.1._el5xen/extra/video4linux/gspca_main.ko

I tried to link 
	/lib/modules/2.6.18-128_.4.1._el5xen/extra
to 
	/lib/modules/2.6.18-128.el5xen/extra
and run a depmod. 

But I got an error message 
	[root at aberlour]# modprobe gspca_main
	FATAL: Error inserting gspca_main (/lib/modules/2.6.18-128.4.1.el5xen/extra/video4linux/gspca_main.ko): Invalid module format


after having discussion (and many tests) with Phil Perry (from ELrepo)
 the conclusion is that their module is not compatible with CentOS XEN

All the posts are here: http://lists.elrepo.org/pipermail/elrepo/2009-August/date.html#23


Can someone help ?
how can I use a gspca driver ?


regards 
philippe







More information about the CentOS-devel mailing list