[CentOS-devel] Upgrading postgresql (Re: CentOS/RHEL 5.3)

Les Mikesell lesmikesell at gmail.com
Thu Jan 22 19:23:38 UTC 2009


Jeff Johnson wrote:
> 
> On Jan 22, 2009, at 2:00 PM, Les Mikesell wrote:
>>>
>>
>> I'd just like to see a realistic approach to updates via packages.
>>
> 
> Reality check:
> 
> You have a postgres upstream devel with years of experience
> packaging postgres and me both saying
>     Don't attempt postgres database upgrades in packaging.
> 
> But create your own virtuality reality approach if you want.
> 

I think you missed my point, which is that RPM packaging doesn't provide 
facilities for what needs to be done.  Postgres upstream is just more 
honest than most in recognizing the problem.  It's not the only thing 
that ever has non-backward-compatible updates.

-- 
   Les Mikesell
    lesmikesell at gmail.com


More information about the CentOS-devel mailing list