[CentOS-devel] [PHP 5.2.6] Feedback / Centos Testing and CentOS Extras

Remi Collet Fedora at FamilleCollet.com
Thu Mar 12 19:46:57 UTC 2009


Paulo Martinez a écrit :


>>> php-mcrypt
>>> php-mhash
>>> php-pecl-Fileinfo
>>>
>>> Deleting this php-modules resolves this (issue of starting httpd):

>>> PHP Warning:  PHP Startup: fileinfo: Unable to initialize module 
>>> \nModule
>>> compiled with module API=20050922, debug=0, thread-safety=0\nPHP
>>> compiled with module API=20060613, debug=0, thread-safety=0\nThese
>>> options need to match\n in Unknown on line 0
>>> PHP Warning:  PHP Startup: mcrypt: Unable to initialize module 
>>> \nModule
>>> compiled with module API=20050922, debug=0, thread-safety=0\nPHP
>>> compiled with module API=20060613, debug=0, thread-safety=0\nThese
>>> options need to match\n in Unknown on line 0
>>> PHP Warning:  PHP Startup: mhash: Unable to initialize module\nModule
>>> compiled with module API=20050922, debug=0, thread-safety=0\nPHP
>>> compiled with module API=20060613, debug=0, thread-safety=0\nThese
>>> options need to match\n in Unknown on line 0
>>>

This should be detect before installation, not on apache start...

That's why Fedora 5.2.x php package provides the new
	php(zend-abi) = 20060613

Which should be required by all pecl extension
/etc/rpm/macros.php (in php-devel) provides usefull macros for this.

>>> I am sure all extra-repo packages
>>>
>>> php-*
>>> php-pecl*
>>>
>>> have to be touched to run also with centosplus candidate php 5.2.x

Note only touch, but probably adapted to also require php(zend-abi),
to avoid installation with incompatible php version.

And some others stuff, like rrdtool-php (and syck-php, graphviz-php,
uuid-php but not available on CentOS, I think)

Regards

+


More information about the CentOS-devel mailing list