[CentOS-devel] kmod update with yum

Farkas Levente lfarkas at lfarkas.org
Tue May 19 15:23:35 UTC 2009


Farkas Levente wrote:
> hi,
> i need some help:-(
> i now spend many hours to find the reason why yum always install kmod
> rpms on centos and never update. currently there is not any weak-updates
> kmod rpm in centos which has more version-release, but as you try to
> update any kmod the same problem will arise. in case of fedora where
> kmod's are hardwired to a given kernel it's not a problem (but those are
> never weak-update kmods), but in case of centos where eg in 5.3 all
> kernel a kabi compatible then we can use none kernel version specific
> kmods. what's more in case of weak-updates kmod when the same package
> has more version installed cause many problems.
> suppose i've got a kmod installed eg:
> # rpm -q kmod-fuse
> kmod-fuse-2.7.4-20.el5
> now i build a new one and try to update with yum update. it's always
> install it and i can't force yum to update it. anybody can tell me the
> reason? of course rpm -U update it.
> 
> imho it's the same reason as the recent dbrd kmod thread where wasn't
> any solution.
> 
> anyway anybody know what is the yum-kmod and what is it good for? and
> try both with/without yum-kmod but the same happened:-(

but for easy test:
http://www.lfarkas.org/linux/packages/centos/5/i386/other/RPMS/kmod-fuse-2.7.4-20.el5.i686.rpm
http://www.lfarkas.org/linux/packages/centos/5/i386/other/RPMS/kmod-fuse-2.7.4-21.el5.i686.rpm
instal the first one on a rhel/centos-5.3 then put the second one into a
repo and yum update and everybody will see the problem:-(

-- 
  Levente                               "Si vis pacem para bellum!"


More information about the CentOS-devel mailing list