[CentOS-devel] deltarpm and presto for centos

Farkas Levente lfarkas at lfarkas.org
Wed Nov 18 15:16:40 UTC 2009


On 11/15/2009 08:28 PM, Jonathan Dieter wrote:
> On Sun, 2009-11-15 at 19:30 +0100, Farkas Levente wrote:
>> ok let make things more specific:
>>
>> deltarpm in epel 3.4-8.el5.1 while in fedora 3.5-0.4.20090913git is
>> there any significant/relevant changes? when do you plan 3.5 release?
> 
> I'm currently building it and will push it to testing ASAP.  The main
> difference is that it supports xz-compressed RPMS (which shouldn't
> matter for CentOS) and it has a python API (which will be useful).
> 
>> i'd be useful to add yum-presto to epel too. at the same time which
>> version required by yum-presto? in rhel/centos-5 yum-3.2.22 included,
>> but i read somewhere (and i can't find now where) that at least
>> yum-3.2.23 required. so what's the correct version?
> 
> I think presto should work with any modern version of yum, including
> 3.2.22.  In fact, I have at various times used it on my CentOS 5 boxes.
> I'll see about branching it for EPEL.
> 
>> also a presto-utils would be useful in epel. rebuilding from fedora
>> presto-utils-0.3.4-3 gives this error:
> <snip>
>> it's be useful to be at least a minimal manual how we can use these
>> tools and and who we can generate deltarpms.
> 
> Fedora is using createrepo, not presto-utils to generate their
> deltarpms.  Presto-utils should be deprecated (or at least, mainly used
> for pruning out old drpms, etc).

FYI:
now i able to do build and run delta update on my systems, but there was
a few problems:
- i use http://infrastructure.fedoraproject.org/'s
createrepo-0.9.8-2.el5 for generating deltarpms and delta repo and use
fedora's yum-presto.
- unfortunately this version of createrepo is not able to generate sha1
checksum for the repo (at least even if i set it on the command line
i've got a python stack trace), but rhel/centos-5 doesn't have sha256 in
python my default so you've to install python-hashlib and add createrepo
to depend on it. imho it's a createrepo bug.
- and also remove the versioned yum req from createrepo since 5.4's yum
is enough.
- but as it generate sha256 checksum i also have to add python-hashlib
req for yum-presto (otherwise it can't check the checksum on the client
side).

ps. another strange problem that in one of our internal rpm the deltarpm
rebuild failed:
------------------------------------------
<delta rebuild>
93%
[=========================================================================-
    ] 521 kB/s | 180 MB     00:25 ETA
//var/cache/yum/xxx-beta-4.2.1-5082/deltas/xxx-4.2.0-4763.el5_4.2.1-5082.el5.i386.drpm:
md5 mismatch of result
<delta rebuild>                                | 193 MB     05:11
Error rebuilding rpm from xxx-4.2.0-4763.el5_4.2.1-5082.el5.i386.drpm!
Will download full package.
Presto reduced the update size by 74% (from 193 M to 51 M).
------------------------------------------
but good to know that fall back to normal rpm is working:-)

-- 
  Levente                               "Si vis pacem para bellum!"


More information about the CentOS-devel mailing list