[CentOS-devel] yum-3.2.8 for Centos 4 backport, part II.

David Hrbáč hrbac.conf at seznam.cz
Fri Jan 29 11:41:13 UTC 2010


Dne 28.1.2010 17:04, William L. Maltby napsal(a):
> On Wed, 2010-01-27 at 08:59 +0100, David Hrbáč wrote:
>> Dne 27.1.2010 8:54, David Hrbáč napsal(a):
>>> 4. run yum check-update --enablerepo=hrb-test
>>> 5. run yum update yum --enablerepo=hrb-test
>>
>> Sorry,
>> should be:
>> 4. run yum check-update --enablerepo=hrb-testing
>> 5. run yum update yum --enablerepo=hrb-testing
> 
> I thought I got it all right, but still have problems. I must apologize
> in that other matters keep me from digging as deep as I normally would,
> so I'm in "just do it best I can and report" mode.
> 
> Current setup is this.
> 
> yum-updateonboot-0.5-2.el4.centos
> yum-metadata-parser-1.1.2-12.el4.hrb.1
> yum-fastestmirror-1.1.16-13.el4.hrb.1
> yum-utils-1.1.16-13.el4.hrb.1
> yum-plugin-priorities-0.0.7-2.c4
> yumex-1.0.2-1.0.c4
> yum-3.2.19-18.el4.hrb.6
> yum-arch-2.2.2-1.el4.rf
> yum-plugin-protectbase-1.1-1.c4
> 
> Tried a simple "yum update glib\*" and got this
> 
> # yum update glib\*
> Loaded plugins: fastestmirror, installonlyn, priorities, protectbase
> /usr/lib/python2.3/site-packages/yum/plugins.py:465: DeprecationWarning:
> registerOpt() will go away in a future version of Yum.
> Please manipulate config.YumConf and config.RepoConf directly.
>   DeprecationWarning)
> Loading mirror speeds from cached hostfile
>  * fasttrack: ftp.linux.ncsu.edu
>  * update: ftp.linux.ncsu.edu
>  * rpmforge: fr2.rpmfind.net
>  * base: www.gtlib.gatech.edu
>  * addons: ftp.linux.ncsu.edu
>  * hrb-stable: fs12.vsb.cz
>  * extras: ftp.linux.ncsu.edu
> 0 packages excluded due to repository protections
> 555 packages excluded due to repository priority protections
> Setting up Update Process
> Resolving Dependencies
> --> Running transaction check
> ---> Package glibc-common.i386 0:2.3.4-2.43.el4_8.1 set to be updated
> ---> Package glibc.i686 0:2.3.4-2.43.el4_8.1 set to be updated
> ---> Package glibc-profile.i386 0:2.3.4-2.43.el4_8.1 set to be updated
> ---> Package glibc-devel.i386 0:2.3.4-2.43.el4_8.1 set to be updated
> ---> Package glibc-utils.i386 0:2.3.4-2.43.el4_8.1 set to be updated
> ---> Package glibc-headers.i386 0:2.3.4-2.43.el4_8.1 set to be updated
> --> Processing Dependency: glibc-devel = 2.3.4-2.43 for package:
> nptl-devel
> --> Running transaction check
> ---> Package nptl-devel.i686 0:2.3.4-2.43.el4_8.1 set to be updated
> --> Finished Dependency Resolution
> /usr/lib/yum-plugins/installonlyn.py:56: YumDeprecationWarning:
> getProvidesNames() will go away in a future version of Yum.
> 
>   if (m.name == instpkg or instpkg in m.po.getProvidesNames()) \
> 
> Dependencies Resolved
> 
> ================================================================================ Package              Arch        Version                   Repository     Size
> ================================================================================Updating:
>  glibc                i686        2.3.4-2.43.el4_8.1        update
> 6.0 M
>  glibc-common         i386        2.3.4-2.43.el4_8.1        update
> 16 M
>  glibc-devel          i386        2.3.4-2.43.el4_8.1        update
> 1.9 M
>  glibc-headers        i386        2.3.4-2.43.el4_8.1        update
> 589 k
>  glibc-profile        i386        2.3.4-2.43.el4_8.1        update
> 1.1 M
>  glibc-utils          i386        2.3.4-2.43.el4_8.1        update
> 112 k
>  nptl-devel           i686        2.3.4-2.43.el4_8.1        update
> 935 k
> 
> Transaction Summary
> ================================================================================Install      0 Package(s)
> Update       7 Package(s)
> Remove       0 Package(s)
> 
> Total download size: 26 M
> Is this ok [y/N]: y
> Downloading Packages:
> Traceback (most recent call last):
>   File "/usr/bin/yum", line 29, in ?
>     yummain.user_main(sys.argv[1:], exit_code=True)
>   File "/usr/share/yum-cli/yummain.py", line 229, in user_main
>     errcode = main(args)
>   File "/usr/share/yum-cli/yummain.py", line 181, in main
>     return_code = base.doTransaction()
>   File "/usr/share/yum-cli/cli.py", line 391, in doTransaction
>     problems = self.downloadPkgs(downloadpkgs,
> callback_total=self.download_callback_total_cb)
>   File "/usr/lib/python2.3/site-packages/yum/__init__.py", line 1123, in
> downloadPkgs
>     remote_pkgs.sort(mediasort)
>   File "/usr/lib/python2.3/site-packages/yum/__init__.py", line 1072, in
> mediasort
>     a = apo.getDiscNum()
>   File "/usr/lib/python2.3/site-packages/yum/packages.py", line 586, in
> getDiscNum
>     if self.basepath is None:
>   File "/usr/lib/python2.3/site-packages/yum/sqlitesack.py", line 151,
> in __getattr__
>     (self.pkgId,)).fetchone()
>   File "/usr/lib/python2.3/site-packages/yum/sqlitesack.py", line 123,
> in _sql_MD
>     executeSQL(cur, sql, *args)
>   File "/usr/lib/python2.3/site-packages/yum/sqlutils.py", line 150, in
> executeSQLPyFormat
>     return cursor.execute(q, p)
>   File
> "/var/tmp/python-sqlite-root//usr/lib/python2.3/site-packages/sqlite/main.py", line 255, in execute
> _sqlite.DatabaseError: no such column: location_base
> 
> I had to C&P the error messages, so if there seems to be dupes, it's
> operator error.
> 
> Sorry I'm not able to be more thorough in my investigations before I
> post.
> 
>>
>> DH
>> <snip sig stuff>
> 

Works,
pretty well:Loaded plugins: fastestmirror, priorities, protect-packages,
protectbase

[root at yumc4 ~]# yum check-update --enablerepo=hrb-testing
--disablerepo=extras
Loaded plugins: fastestmirror, priorities, protect-packages, protectbase
Loading mirror speeds from cached hostfile
 * update: merlin.fit.vutbr.cz
 * base: merlin.fit.vutbr.cz
 * hrb-testing: fs12.vsb.cz
 * addons: merlin.fit.vutbr.cz
 * hrb-stable: fs12.vsb.cz
55 packages excluded due to repository protections
[root at yumc4 ~]#

Do you have installonlyn plug-in installed? There's no such plug-in
within this version. It's already included as a core feature.
David Hrbáč


More information about the CentOS-devel mailing list