[CentOS-devel] DRBD 8.3.9

Ned Slider ned at unixmail.co.uk
Tue Nov 2 15:34:44 EDT 2010


Ralph Angenendt wrote:
> Am 02.11.10 15:03, schrieb Jörgen Maas:
>> On Tue, Nov 2, 2010 at 2:11 PM, Fabian Arrotin
>> <fabian.arrotin at arrfab.net> wrote:
>>> Another one can argue that if those sysadmins didn't update their
>>> machine prior to the drbd83 update, some 'bug reports' will appear on
>>> bugs.centos.org to say that the latest drbd update broke their cluster .
>>>
>>> Thoughts about this ?
>> I think that fetching and installing the required dependencies is the way to go.
>>
>> In reality it's not always possible to have up to date systems,
>> especially in an enterprise setting.
>> And that may, very likely, have nothing to do with the admins themselves.
> 
> I don't like hard "Requires:" like those, but in this case there is a
> new drbd83-kmod package in testing which has that requirement.
> 

The solution as pointed out by Martin in the bug report (comment #23) is 
to use a Conflicts for the buggy package, not a Requires for the newer 
(fixed) package.




More information about the CentOS-devel mailing list