[CentOS-devel] Dependency missing for ipa-server

Fabian Arrotin fabian.arrotin at arrfab.net
Thu Nov 17 10:54:24 EST 2011


On 11/17/2011 04:48 PM, Baptiste AGASSE wrote:
> Hi all,
> 
> I've an up to date test vm running CentOS 6.0 with CR repo.
> 
> I've tried to install ipa-server for testing purposes but the "yum install ipa-server" ends with dependencies problems:
> # yum install ipa-server
> [...]
> ---> Package ipa-server.x86_64 0:2.0.0-23.el6_1.2 will be installed
> --> Processing Dependency: pki-silent >= 9.0.0 for package: ipa-server-2.0.0-23.el6_1.2.x86_64
> --> Processing Dependency: pki-ca >= 9.0.0 for package: ipa-server-2.0.0-23.el6_1.2.x86_64
> ---> Package setools-libs.x86_64 0:3.3.7-4.el6 will be installed
> --> Finished Dependency Resolution
> Error: Package: ipa-server-2.0.0-23.el6_1.2.x86_64 (cr)
>            Requires: pki-ca >= 9.0.0
> Error: Package: ipa-server-2.0.0-23.el6_1.2.x86_64 (cr)
>            Requires: pki-silent >= 9.0.0
> 
> I know that ipa-server is new in RHEL 6.1, consequently, this packages (and maybe some deps) are not present in CentOS 6, but ipa-server's package is present in CR repo. When i browsed RHEL's ftp on redhat i viewed "pki-core" package that's not present at this time in CentOS's CR repo.
> 
> So, my question is: This package will be in CR repo or it will be released when C6.1 be ready ?
> 

We've seen that issue in the CR repo (through repoclosure) but i don't
know if it will be fixed in CR , as it's not a security update for 6.0,
and QA has started for 6.1 (that will include all those packages)

Fabian


More information about the CentOS-devel mailing list