[CentOS-devel] Testers needed: nx (upgrade to the 3.5.0 series) and freenx (SELinux fix)

Ljubomir Ljubojevic office at plnet.rs
Tue Oct 25 15:59:40 EDT 2011


Vreme: 10/25/2011 09:24 PM, Farkas Levente piše:
>> What to include as 'Requires' can be tricky. NX needs a desktop for
>> sure but it can be gnome or KDE or even something else. So far, it's
>> up to the user to make sure X and a desktop are available when using
>> NX.
>
> unfortunately there is no RequiresGroup in rpm:-(
> even it'd be useful for me too:-)
>

Since Groups can have diverse packages even on the systems with same 
base, RHEL 6.x multiple versions are fine example, there never can be 
"RequiresGroup". What would be nice to see would be "Recomended:", or 
"Optional:" instead of "Requires:", so you can install additional 
packages, but they would not be removed if you remove main package.

Is "dirty solution" where rpm package would use post-install script to 
run yum command (or set "due to be installed") to install all optional 
packages (if user agrees)?

-- 

Ljubomir Ljubojevic
(Love is in the Air)
PL Computers
Serbia, Europe

Google is the Mother, Google is the Father, and traceroute is your
trusty Spiderman...
StarOS, Mikrotik and CentOS/RHEL/Linux consultant


More information about the CentOS-devel mailing list