[CentOS-devel] Test OpenStack Essex builds for CentOS

Florian La Roche Florian.LaRoche at gmx.net
Mon Sep 10 01:06:46 EDT 2012


> A test install with EPEL enabled shows that python-boto, python-eventlet
> and python-httplib2 are taken with newer versions from EPEL.

Now also python-nova is newer in EPEL with the below spec changes. So you should
add dnsmasq-utils as an extra dependency in case of using EPEL.

best regards,

Florian La Roche



--- Look at changes from openstack-nova-2012.1.1-15.el6.alt.src.rpm to openstack-nova-2012.1.1-15.el6.src.rpm.
old:
total 52
drwxrwxr-x. 2 laroche laroche  4096 Sep 10 07:05 .
drwxrwxr-x. 4 laroche laroche  4096 Sep 10 07:05 ..
-rw-rw-r--. 1 laroche laroche 42300 Sep 10 07:05 openstack-nova.spec
new:
total 52
drwxrwxr-x. 2 laroche laroche  4096 Sep 10 07:05 .
drwxrwxr-x. 4 laroche laroche  4096 Sep 10 07:05 ..
-rw-r--r--. 1 laroche laroche 42310 Sep 10 07:05 openstack-nova.spec
diff -urN old/openstack-nova.spec new/openstack-nova.spec
--- old/openstack-nova.spec     2012-09-10 07:05:13.499565538 +0200
+++ new/openstack-nova.spec     2012-09-10 07:05:13.698754289 +0200
@@ -189,8 +189,8 @@
 Requires:         vconfig
 Requires:         radvd
 Requires:         bridge-utils
-# available in Preview channel
-Requires:         dnsmasq-utils
+#TODO: Enable when available in RHEL 6.3
+#Requires:         dnsmasq-utils
 # tunctl is needed where `ip tuntap` is not available
 Requires:         tunctl
 
@@ -338,6 +338,8 @@
 Requires:         python-paramiko
 
 Requires:         python-qpid
+Requires:         python-kombu
+Requires:         python-amqplib
 
 Requires:         python-daemon
 Requires:         python-eventlet
@@ -886,8 +888,6 @@
 
 * Fri Jun 22 2012 Pádraig Brady <P at draigBrady.com> - 2012.1.1-1
 - Update to essex stable release 2012.1.1
-
-* Fri Jun 22 2012 Pádraig Brady <P at draigBrady.com> - 2012.1-13
 - Improve performance and stability of file injection
 - add upstart jobs, alternative to sysv initscripts
 


More information about the CentOS-devel mailing list