[Centos] Help: Apache2, Tomcat5 and jk2_connector

Fernando Mustieles nando_musti at yahoo.com
Mon Dec 6 16:32:44 UTC 2004


Hello, Does any have Apache 2.0.49 with tomcat 5.5.4
and jakarta-tomcat-connectors-jk2-2.0.4 working???

Apache was allready installed with CentOS 3
I installed tomcat with it's tar.gz file and
instalation was good.
but I installed first the j2sdk-1_4_2_06-linux-i586
java version...
 everything was OK...

but when I try to install the jakarta-tomcat-connector
I get an error when executing the make command...

./configure (with parameters) work ok, with no error..

but with make I got the following:

# make
list=' server/apache2'; \
for i in $list; do \
        echo "Making $target in $i"; \
        if test "$i" != "."; then \
        (cd $i && make) || exit 1; \
fi; \
done;
Making  in server/apache2
make[1]: Entering directory
`/home/jakarta-tomcat-connectors-jk2-2.0.4-src/jk/native2/server/apache2'
mkdir -p
../../../build/jk2/apache2/usr/lib/httpd/modules
/bin/sh /usr/bin/libtool --silent  --mode=compile gcc 
-O2 -g -pipe -march=i386 -mcpu=i686
-DSSL_EXPERIMENTAL_
ENGINE -I/usr/kerberos/include -pthread    -DLINUX=2
-D_REENTRANT -D_XOPEN_SOURCE=500 -D_BSD_SOURCE
-D_SVID_SO
URCE -D_GNU_SOURCE   -I../../include
-I/usr/include/httpd
-I/rpmbuild/centos/rpm/BUILD/httpd-2.0.46/prefork/sr
clib/apr-util/include
/rpmbuild/centos/rpm/BUILD/httpd-2.0.46/srclib/apr-util/include
-I/rpmbuild/centos/rpm/B
UILD/httpd-2.0.46/prefork/srclib/apr/include
/rpmbuild/centos/rpm/BUILD/httpd-2.0.46/srclib/apr/include
-I /us
r/java/j2sdk1.4.2_06/include -I
/usr/java/j2sdk1.4.2_06/include/linux 
-DCHUNK_SIZE=4096 -DUSE_APACHE_MD5 -DHA
VE_JNI  -c ../../common/jk_channel_apr_socket.c -o
../../../build/jk2/apache2/jk_channel_apr_socket.lo
gcc: cannot specify -o with -c or -S and multiple
compilations
make[1]: ***
[../../../build/jk2/apache2/jk_channel_apr_socket.lo]
Error 1
make[1]: Leaving directory
`/home/jakarta-tomcat-connectors-jk2-2.0.4-src/jk/native2/server/apache2'
make: *** [jk2-build] Error 1


Any ideas of the problem and how to fix it....
or should I use another versions of tomcat and the
connector.

In advance thanks for your help...


		
__________________________________ 
Do you Yahoo!? 
The all-new My Yahoo! - Get yours free! 
http://my.yahoo.com 
 




More information about the CentOS mailing list