[Centos] Postfix Install error

Mike Kercher mike at CamaroSS.net
Sat Dec 18 03:23:57 UTC 2004


I'm trying to install postfix-2.0.16-14.RHEL on a newly installed CentOS 3.3
boxen and I get the following error:

Preparing...                ###########################################
[100%]
   1:postfix                ###########################################
[100%]
link /usr/share/man/man8/sendmail.8.gz incorrect for slave mta-sendmailman
(/usr/share/man/man1/sendmail.1.gz mta-sendmailman)
error: %trigger(postfix-2.0.20-1.centos3.1) scriptlet failed, exit status 2
link /usr/share/man/man8/sendmail.8.gz incorrect for slave mta-sendmailman
(/usr/share/man/man1/sendmail.1.gz mta-sendmailman)
link /usr/share/man/man8/sendmail.8.gz incorrect for slave mta-sendmailman
(/usr/share/man/man1/sendmail.1.gz mta-sendmailman)
error: %trigger(postfix-2.0.20-1.centos3.1) scriptlet failed, exit status 2
link /usr/share/man/man8/sendmail.8.gz incorrect for slave mta-sendmailman
(/usr/share/man/man1/sendmail.1.gz mta-sendmailman)


I recompiled the .src.rpm for 2.0.20-1 and installed it and things have been
screwy since.  I cannot rpm -e ANY postfix package, yum remove doesn't work
either.  Any ideas how to get around this error?

Mike




More information about the CentOS mailing list