[Centos] Problems migrating from WBEL

Jason Dixon jason at dixongroup.net
Thu Dec 30 05:03:56 UTC 2004


Hi folks:

I've recently migrated one of my production servers (bad Jason!) from 
WBEL to CentOS 3.3 using Donavan's instructions in the FAQ 
(http://www.centos.org/modules/smartfaq/faq.php?faqid=19).  While it 
was as painless as the document suggests, I've run into problems with 
postgrey (a postfix greylisting daemon) on my server.  Whenever I try 
to start postgrey, I get the following error (trimmed from maillog):

ERROR: can't create DB environment: No such file or directory

A little research led me to find the error was caused by a call to 
BerkeleyDB::Env->new() in postgrey.  I can recreate it in a simple Perl 
one-liner:

perl -e 'use BerkeleyDB; my $db = BerkeleyDB::Env->new() or die "blah";'

This leads me to believe that something is wrong with db4, so I 
upgraded (--force) to the CentOS db4 package.  Unfortunately, this had 
no effect.  Speaking with Dag in IRC a couple nights back, he believes 
my only recourse may be to "pin" my apt sources and attempt to upgrade 
all of my WBEL-based packages to their CentOS counterparts.  I would 
really like to avoid this;  if necessary, I think I'd prefer to try and 
upgrade from the 3.3 ISO.

Anyone have any thoughts or suggestions on this?

Thanks,

--
Jason Dixon
DixonGroup Consulting
http://www.dixongroup.net




More information about the CentOS mailing list