[CentOS] yum upgrade on 3.4 and spamassassin

Johnny Hughes mailing-lists at hughesjr.com
Wed Mar 30 13:12:35 UTC 2005


On Tue, 2005-03-29 at 23:26 -0800, Francois Caen wrote:
> Hello,
> 
> I run CentOS 3.4 on 3 machines (i386). Original yum.conf
> 
> If I do a yum update: 
> No actions to take
> 
> If I do a yum upgrade a machine that has no spamassassin: 
> No actions to take
> 
> If I do a yum upgrade on 2 machines that have
> perl-Mail-SpamAssassin-3.0.1-1 installed (3rd party rpm, more recent
> than the CentOS/RHEL one):
> 
> I will do the following:
> [update: spamassassin 2.55-3.4.i386]
> I will install/upgrade these to satisfy the dependencies:
> [deps: perl-Time-HiRes 1.38-3.i386]
> Is this ok [y/N]:
> 
> Could someone please explain this behavior? Why is yum upgrade trying
> to upgrade a package that is a newer 3rd party rpm, with a different
> name?

The why must be that something you have installed must require
"spamassassin"

download both rpms and do:

rpm --requires -qp package_name

and

rpm --provides -qp package_name

then you can see what yum uses from each package to solve
dependencies ... something is telling yum that you need ... and don't
have spamassassin.  I bet that the other package doesn't provide
spamassassin.
-------------- next part --------------
A non-text attachment was scrubbed...
Name: not available
Type: application/pgp-signature
Size: 189 bytes
Desc: This is a digitally signed message part
Url : http://lists.centos.org/pipermail/centos/attachments/20050330/35f2e277/attachment.bin


More information about the CentOS mailing list