[CentOS] VPN via PPTP and MPPE

James B. Byrne ByrneJB at Harte-Lyne.ca
Wed Nov 2 04:53:36 UTC 2005


On 1 Nov 2005 at 11:25, Joe Pruett wrote:

> on the windows box deep in the network properties for the vpn you'll
> find the 'use default gateway on this interface' or something very much
> like that.  uncheck that and then regular internet traffic will not go
> over the vpn. 

Thank you.  I found a fairly well written faq on what can go wrong 
with vpn, which of course I cannot find at the moment.  The basic 
problem with my setup as originally given is that VPNs cannot connect 
over IPs belonging to the same netblock as the physical NICs.   So 
the client end has to have an IP address assigned by the pptpd that 
is on a different netblock from that assigned to its NIC.

I changed the client side IP address asignment and I can now get a 
VPN link to the PPTPD host, but I cannot get a route off that box.  
Once I get past that problem then I will post a summary of whaI did.  
This is evidently a routing issue, as you have pointed out, but one 
that is probably a by product of some configuration error I have made 
to the pptpd options.

Regards,
Jim


-- 

***     e-mail is NOT a secure channel     ***
James B. Byrne                mailto:ByrneJB.<token>@Harte-Lyne.ca
Harte & Lyne Limited          http://www.harte-lyne.ca
9 Brockley Drive              vox: +1 905 561 1241
Hamilton, Ontario             fax: +1 905 561 0757
Canada  L8E 3CE               delivery <token> = hal



More information about the CentOS mailing list