[CentOS] FREENX - error 1004 - CENTOS 4.2

Adriano Frare alfrare at e-alinux.com
Sun Nov 6 15:30:40 UTC 2005


Dear Friends.

When I connect with CENTOS 4.2 by windows XP (client version 1.4.092), I 
have received follow message:

NX> 1004 Error: Session did not start.
NX> 504 Session startup failed.
NX> 999 Bye


Below I show log file

================= BEGIN ==========================
-- NX SERVER START: -c /usr/NX/bin/nxserver
HELLO NXSERVER - Version 1.4.0-04 OS (GPL)
NX> 105 hello NXCLIENT - Version 1.4.0
NX> 134 Accepted protocol: 1.4.0
NX> 105 SET SHELL_MODE SHELL
NX> 105 SET AUTH_MODE PASSWORD
NX> 105 login
NX> 101 User: afrare
NX> 102 Password:
Info: Auth method: ssh
NX> 103 Welcome to: srv001.conntrust.com user: afrare
NX> 105 listsession --user="afrare" --status="Suspended","Running" 
--geometry="1440x900x32+render" --type="unix-console"
NX> 127 Sessions list of user 'afrare' for reconnect:

Display Type             Session ID                       Options  Depth 
Screen         Status      Session Name
  ------- ---------------- -------------------------------- -------- 
----- -------------- ----------- ------------------------------


NX> 148 Server capacity: not reached for user: afrare
NX> 105 startsession --session="192.168.1.5" --type="unix-application" 
--application="xterm" --cache="1M" --images="4M" 
--cookie="c29632dfda9b8481d9b4261d767ed26a" --link="modem" 
--virtualdesktop="1" --kbtype="pc102/br" --nodelay="1" --encryption="1" 
--backingstore="never" --geometry="fullscreen" --media="0" 
--agent_server="" --agent_user="" --agent_password="" 
--screeninfo="800x600x32+render"

user=afrare&userip=192.168.1.200&uniqueid=9090722F109AEDB683326401DB1B9526&display=1000&&session=192.168.1.5&type=unix-application&application=xterm&cache=1M&images=4M&cookie=c29632dfda9b8481d9b4261d767ed26a&link=modem&virtualdesktop=1&kbtype=pc102/br&nodelay=1&encryption=1&backingstore=never&geometry=fullscreen&media=0&agent_server=&agent_user=&agent_password=&screeninfo=800x600x32+render
afrare at 127.0.0.1's password:
NX> 1000 NXNODE - Version 1.4.0-04 OS (GPL)
user=afrare&userip=192.168.1.200&uniqueid=9090722F109AEDB683326401DB1B9526&display=1000&&session=192.168.1.5&type=unix-application&application=xterm&cache=1M&images=4M&cookie=c29632dfda9b8481d9b4261d767ed26a&link=modem&virtualdesktop=1&kbtype=pc102/br&nodelay=1&encryption=1&backingstore=never&geometry=fullscreen&media=0&agent_server=&agent_user=&agent_password=&screeninfo=800x600x32+render
NX> 1004 Error: Session did not start.
NX> 504 Session startup failed.
NX> 999 Bye

================= END ============================


Thanks for help


Adriano



More information about the CentOS mailing list