[CentOS] yum update - Glibc Problem

Lee W lee at unassemble.co.uk
Wed Nov 16 22:32:38 UTC 2005


Hi,

I've just done a fresh install of Centos 4.0 on a Via C3 Based system
using the Centos DVD I downloaded a while ago.

Then install goes though fine as does running 'yum check-update'. 
However when running the actual 'yum update', it downloads all the
headers but afterwards displays the following errors:-

--> Processing Dependency: glibc-common = 2.3.4-2 for package: glibc
--> Finished Dependency Resolution
Error: Missing Dependency: glibc-common = 2.3.4-2 is needed by package glibc

I've checked using 'rpm -q glibc-common' that the appropriate version is
installed (The system wouldn't run otherwise would it?):-

[root at doc ~]# rpm -q glibc-common
glibc-common-2.3.4-2

Has anyone else experienced this problem, I'm sure that I have been able
to install Centos 4 on a Via system before, so does anyone know what (if
anything) has changed with the recent versions of Glibc?

Thanks in advance for any assistance offered

Regards

Lee





More information about the CentOS mailing list