[CentOS] yum update problems

William Warren hescominsoon at emmanuelcomputerconsulting.com
Thu Oct 13 15:21:00 UTC 2005


I am running 4.1.  I have all proxies out of the way.  One machine does 
the following:
[root at enoch ~]# yum update
Setting up Update Process
Setting up Repos
dag                       100% |=========================| 1.1 kB    00:00
update                    100% |=========================|  951 B    00:00
base                      100% |=========================| 1.1 kB    00:00
addons                    100% |=========================|  951 B    00:00
extras                    100% |=========================| 1.1 kB    00:00
Reading repository metadata in from local files
dag       : ################################################## 2605/2605
update    : ################################################## 16/16
base      : ################################################## 1406/1406
extras    : ################################################## 33/33
Resolving Dependencies
--> Populating transaction set with selected packages. Please wait.
---> Package openssl.i686 0:0.9.7a-43.4 set to be updated
---> Package util-linux.i386 0:2.12a-16.EL4.12 set to be updated
--> Running transaction check
--> Processing Dependency: pam >= 0.77-66.8 for package: util-linux
--> Processing Dependency: libaudit.so.0 for package: util-linux
--> Finished Dependency Resolution
Error: Missing Dependency: pam >= 0.77-66.8 is needed by package util-linux
Error: Missing Dependency: libaudit.so.0 is needed by package util-linux


Mind you both pakcages ae actually installed.

For the other machine i get:
[root at joshua ~]# yum update
Setting up Update Process
Setting up Repos
dag                       100% |=========================| 1.1 kB    00:00
update                    100% |=========================|  951 B    00:00
base                      100% |=========================| 1.1 kB    00:00
addons                    100% |=========================|  951 B    00:00
extras                    100% |=========================| 1.1 kB    00:00
Reading repository metadata in from local files
primary.xml.gz            100% |=========================| 919 kB    00:00
MD Read   : ################################################## 2605/2605
dag       : ################################################## 2605/2605
primary.xml.gz            100% |=========================| 4.2 kB    00:00
MD Read   : ################################################## 16/16
update    : ################################################## 16/16
primary.xml.gz            100% |=========================| 466 kB    00:00
http://mirror.centos.org/centos/4/os/i386/repodata/primary.xml.gz: 
[Errno -1] Metadata file does not match checksum
Trying other mirror.
Error: failure: repodata/primary.xml.gz from base: [Errno 256] No more 
mirrors to try.


I have used yum clean all and rebooted.  no dice.  Any ideas?

-- 
My "Foundation" verse:
Isa 54:17  No weapon that is formed against thee shall prosper; and 
every tongue that shall rise against thee in judgment thou shalt 
condemn. This is the heritage of the servants of the LORD, and their 
righteousness is of me, saith the LORD.

-- carpe ductum -- "Grab the tape"
CDTT (Certified Duct Tape Technician)

Linux user #322099
Machines:
206822
256638
276825
http://counter.li.org/



More information about the CentOS mailing list