[CentOS] Yum Dependency errors

Jay jaybeattie at gmail.com
Wed Oct 19 04:17:29 UTC 2005


Greetings,
This is a new install on CentOs 4.1 dvd  from a couple weeks ago. The
initial yum updates worked fine but now There are about 15 things that
get dependency errors and yum will not
install the updates.  Rebuild the RPM database,  removed
/var/cache/yum/* , yum update yum for the latest version and the
errors still exist. When you query the rpm database the dependency are
installed.
Here are some examples:

# yum install gtkhtml3
Setting up Install Process
Setting up repositories
update                    100% |=========================|  951 B    00:00
base                      100% |=========================| 1.1 kB    00:00
addons                    100% |=========================|  951 B    00:00
extras                    100% |=========================| 1.1 kB    00:00
Reading repository metadata in from local files
Parsing package install arguments
Resolving Dependencies
--> Populating transaction set with selected packages. Please wait.
---> Package gtkhtml3.x86_64 0:3.3.2-6.EL set to be updated
--> Running transaction check
--> Processing Dependency: gtkhtml3 = 3.3.2-3 for package: gtkhtml3-devel
--> Finished Dependency Resolution
Error: Missing Dependency: gtkhtml3 = 3.3.2-3 is needed by package
gtkhtml3-devel
# rpm -q -a | grep gtkhtm
gtkhtml2-devel-2.6.2-1
gtkhtml2-2.6.2-1
gtkhtml2-2.6.2-1
gtkhtml3-3.3.2-3
gtkhtml3-devel-3.3.2-3
gtkhtml3-devel-3.3.2-6.EL


Error: Missing Dependency: gcc4 = 4.0.0-0.14.EL4 is needed by package
gcc4-c++

Error: Missing Dependency: gcc4 = 4.0.0-0.14.EL4 is needed by package
gcc4-gfortran
------------------------------------------------------------
 rpm -q -a | grep gcc4
gcc4-gfortran-4.0.1-4.EL4.2
gcc4-c++-4.0.0-0.14.EL4
gcc4-gfortran-4.0.0-0.14.EL4
gcc4-c++-4.0.1-4.EL4.2
gcc4-4.0.0-0.14.EL4


Thanks
-Jay



More information about the CentOS mailing list