[CentOS] raid 1 problem

rado rado at rivers-bend.com
Thu Oct 20 02:27:54 UTC 2005


Hi! 
	A few days back ...I upgraded using yum update. I did this on 3
machines of which 2 of the machines are mirrors. I have no problems
w/the other 2 machines which leads me to believe that the fault lies in
2.6 but rather I think I have a hard drive failure.
while the system is trying to boot up.

it goes to: grub stage 2....that's the first thing I seem to find
outside of taking forever to find the drives.

then when it is booting....lots of hdc errors

here's an excerpt from /var/log/messages:

ide: failed opcode was: unknown
Oct 19 20:34:46 rbmain1 kernel: end_request: I/O error, dev hdc, sector
552
Oct 19 20:34:46 rbmain1 kernel: Buffer I/O error on device hdc, logical
block 69
Oct 19 20:34:46 rbmain1 kernel: hdc: drive not ready for command
Oct 19 20:34:46 rbmain1 kernel: hdc: status error: status=0x10
{ SeekComplete }
Oct 19 20:34:46 rbmain1 kernel: 
Oct 19 20:34:46 rbmain1 kernel: ide: failed opcode was: unknown
Oct 19 20:34:46 rbmain1 kernel: hdc: drive not ready for command
Oct 19 20:34:46 rbmain1 kernel: hdc: status error: status=0x10
{ SeekComplete }
Oct 19 20:34:46 rbmain1 kernel: 
Oct 19 20:34:46 rbmain1 kernel: ide: failed opcode was: unknown
Oct 19 20:34:46 rbmain1 kernel: hdc: drive not ready for command
Oct 19 20:34:46 rbmain1 kernel: hdc: status error: status=0x10
{ SeekComplete }
Oct 19 20:34:46 rbmain1 kernel: 
Oct 19 20:34:46 rbmain1 kernel: ide: failed opcode was: unknown
Oct 19 20:34:46 rbmain1 kernel: hdc: drive not ready for command
Oct 19 20:34:46 rbmain1 kernel: hdc: status error: status=0x10
{ SeekComplete }
Oct 19 20:34:46 rbmain1 kernel: 
Oct 19 20:34:46 rbmain1 kernel: ide: failed opcode was: unknown
Oct 19 20:34:46 rbmain1 kernel: hdc: drive not ready for command
Oct 19 20:34:46 rbmain1 kernel: ide1: reset: success
Oct 19 20:34:46 rbmain1 kernel: hdc: status error: status=0x10
{ SeekComplete }
Oct 19 20:34:46 rbmain1 kernel: 
Oct 19 20:34:46 rbmain1 kernel: ide: failed opcode was: unknown
Oct 19 20:34:46 rbmain1 kernel: hdc: drive not ready for command
Oct 19 20:34:46 rbmain1 kernel: hdc: status error: status=0x10
{ SeekComplete }
Oct 19 20:34:46 rbmain1 kernel: 
Oct 19 20:34:46 rbmain1 kernel: ide: failed opcode was: unknown
Oct 19 20:34:46 rbmain1 kernel: hdc: drive not ready for command
Oct 19 20:34:46 rbmain1 kernel: hdc: status error: status=0x10
{ SeekComplete }
Oct 19 20:34:46 rbmain1 kernel: 
Oct 19 20:34:46 rbmain1 kernel: ide: failed opcode was: unknown
Oct 19 20:34:46 rbmain1 kernel: hdc: drive not ready for command
Oct 19 20:34:46 rbmain1 kernel: hdc: status error: status=0x10
{ SeekComplete }
Oct 19 20:34:46 rbmain1 kernel: 
Oct 19 20:34:46 rbmain1 kernel: ide: failed opcode was: unknown
Oct 19 20:34:46 rbmain1 kernel: hdc: drive not ready for command
Oct 19 20:34:46 rbmain1 kernel: ide1: reset: success
Oct 19 20:34:46 rbmain1 kernel: hdc: status error: status=0x10
{ SeekComplete }
Oct 19 20:34:46 rbmain1 kernel: 
Oct 19 20:34:46 rbmain1 kernel: ide: failed opcode was: unknown
Oct 19 20:34:46 rbmain1 kernel: end_request: I/O error, dev hdc, sector
560
Oct 19 20:34:46 rbmain1 kernel: Buffer I/O error on device hdc, logical
block 70
Oct 19 20:34:46 rbmain1 kernel: hdc: drive not ready for command
Oct 19 20:34:46 rbmain1 kernel: hdc: status error: status=0x10
{ SeekComplete }
Oct 19 20:34:46 rbmain1 kernel: 
Oct 19 20:34:46 rbmain1 kernel: ide: failed opcode was: unknown
Oct 19 20:34:46 rbmain1 kernel: hdc: drive not ready for command
Oct 19 20:34:46 rbmain1 kernel: hdc: status error: status=0x10
{ SeekComplete }
Oct 19 20:34:46 rbmain1 kernel: 
Oct 19 20:34:46 rbmain1 kernel: ide: failed opcode was: unknown
Oct 19 20:34:46 rbmain1 kernel: hdc: drive not ready for command
Oct 19 20:34:46 rbmain1 kernel: hdc: status error: status=0x10
{ SeekComplete }
Oct 19 20:34:46 rbmain1 kernel: 
Oct 19 20:34:46 rbmain1 kernel: ide: failed opcode was: unknown
Oct 19 20:34:46 rbmain1 kernel: hdc: drive not ready for command
Oct 19 20:34:46 rbmain1 kernel: hdc: status error: status=0x10
{ SeekComplete }
Oct 19 20:34:46 rbmain1 kernel: 
Oct 19 20:34:46 rbmain1 kernel: ide: failed opcode was: unknown
Oct 19 20:34:46 rbmain1 kernel: hdc: drive not ready for command
Oct 19 20:34:46 rbmain1 kernel: ide1: reset: success
Oct 19 20:34:46 rbmain1 kernel: hdc: status error: status=0x10
{ SeekComplete }
Oct 19 20:34:46 rbmain1 kernel: 
Oct 19 20:34:46 rbmain1 kernel: ide: failed opcode was: unknown
Oct 19 20:34:46 rbmain1 kernel: hdc: drive not ready for command
Oct 19 20:34:46 rbmain1 kernel: hdc: status error: status=0x10
{ SeekComplete }
Oct 19 20:34:46 rbmain1 kernel: 
Oct 19 20:34:46 rbmain1 kernel: ide: failed opcode was: unknown
Oct 19 20:34:46 rbmain1 kernel: hdc: drive not ready for command
Oct 19 20:34:46 rbmain1 kernel: hdc: status error: status=0x10
{ SeekComplete }
Oct 19 20:34:46 rbmain1 kernel: 
Oct 19 20:34:46 rbmain1 kernel: ide: failed opcode was: unknown
Oct 19 20:34:46 rbmain1 kernel: hdc: drive not ready for command
Oct 19 20:34:46 rbmain1 kernel: hdc: status error: status=0x10
{ SeekComplete }
Oct 19 20:34:46 rbmain1 kernel: 
Oct 19 20:34:46 rbmain1 kernel: ide: failed opcode was: unknown
Oct 19 20:34:46 rbmain1 kernel: hdc: drive not ready for command
Oct 19 20:34:46 rbmain1 kernel: ide1: reset: success
Oct 19 20:34:46 rbmain1 kernel: hdc: status error: status=0x10
{ SeekComplete }
Oct 19 20:34:46 rbmain1 kernel: 
Oct 19 20:34:46 rbmain1 kernel: ide: failed opcode was: unknown
Oct 19 20:34:46 rbmain1 kernel: end_request: I/O error, dev hdc, sector
568
Oct 19 20:34:46 rbmain1 kernel: Buffer I/O error on device hdc, logical
block 71
Oct 19 20:34:46 rbmain1 kernel: hdc: drive not ready for command
Oct 19 20:34:46 rbmain1 kernel: hdc: status error: status=0x10
{ SeekComplete }


please be gentle w/me as, yes, I do run raided systems but just started
doing it recently and I have no experience troubleshooting it etc but
very willing to learn.

I know, I probably don't have all the info that y'all probably need but
I will surely get it and if someone would like to take this off the msg
list, that would sure be ok as well.

I swapped data cables w/others but this system still complains the same
stuff. I think it's a hard drive but I want y'all to teach me how to
really diagnose this. 

Also, say it's a hard drive. In this system, the raided drives are 1
maxtor 100gb and 1 wd 100gb....Now would it be possible to put a 200 gb
in place of the faulty drive? Could that extra space be used...I don't
care one way other just wondering is all

thx y'all,

John Rose

-- 
My wife is always bitching..."I'm so sick of diapers!". I don't know why
she's bitching at me...it's her mom and dad not mine!




More information about the CentOS mailing list