[CentOS] Yum update crashed, now I have lots of missing deps

Remco Barendse redhat at barendse.to
Fri Oct 21 07:35:20 UTC 2005


During yum update my box crashed (I frequently have this on Centos 4 
x86_64 boxes)

---> Package kdebase.x86_64 6:3.3.1-5.8 set to be updated
--> Running transaction check
--> Processing Dependency: system-config-printer = 0.6.116-1.centos4.1 for 
package: system-config-printer-gui
--> Processing Dependency: glibc-devel = 2.3.4-2.9 for package: nptl-devel
--> Processing Dependency: gcc = 3.4.3-22.1 for package: gcc-objc
--> Processing Dependency: openssh = 3.9p1-8.RHEL4.4 for package: 
openssh-clients
--> Processing Dependency: gcc = 3.4.3-22.1 for package: gcc-gnat
--> Processing Dependency: gcc4 = 4.0.0-0.14.EL4 for package: 
libmudflap-devel
--> Processing Dependency: kdebase = 6:3.3.1-5.5 for package: 
kdebase-devel
--> Processing Dependency: gcc = 3.4.3-22.1 for package: gcc-g77
--> Processing Dependency: openoffice.org = 1.1.2-24.6.0.EL4 for package: 
openoffice.org-i18n
--> Processing Dependency: gcc4 = 4.0.0-0.14.EL4 for package: gcc4-c++
--> Processing Dependency: gcc = 3.4.3-22.1 for package: gcc-c++
--> Processing Dependency: gcc4 = 4.0.0-0.14.EL4 for package: 
gcc4-gfortran
--> Processing Dependency: gcc = 3.4.3-22.1 for package: gcc-java
--> Processing Conflict: initscripts conflicts diskdumputils < 1.1.0
--> Finished Dependency Resolution
Error: Missing Dependency: system-config-printer = 0.6.116-1.centos4.1 is 
needed by package system-config-printer-gui
Error: Missing Dependency: glibc-devel = 2.3.4-2.9 is needed by package 
nptl-devel
Error: Missing Dependency: gcc = 3.4.3-22.1 is needed by package gcc-objc
Error: Missing Dependency: openssh = 3.9p1-8.RHEL4.4 is needed by package 
openssh-clients
Error: Missing Dependency: gcc = 3.4.3-22.1 is needed by package gcc-gnat
Error: Missing Dependency: gcc4 = 4.0.0-0.14.EL4 is needed by package 
libmudflap-devel
Error: Missing Dependency: kdebase = 6:3.3.1-5.5 is needed by package 
kdebase-devel
Error: Missing Dependency: gcc = 3.4.3-22.1 is needed by package gcc-g77
Error: Missing Dependency: openoffice.org = 1.1.2-24.6.0.EL4 is needed by 
package openoffice.org-i18n
Error: Missing Dependency: gcc4 = 4.0.0-0.14.EL4 is needed by package 
gcc4-c++
Error: Missing Dependency: gcc = 3.4.3-22.1 is needed by package gcc-c++
Error: Missing Dependency: gcc4 = 4.0.0-0.14.EL4 is needed by package 
gcc4-gfortran
Error: Missing Dependency: gcc = 3.4.3-22.1 is needed by package gcc-java
Error: initscripts conflicts with diskdumputils < 1.1.0


I already tried rpm --rebuilddb

Anyone have an idea how to fix this or how to reverse the update?

Thanks a 1,000,000 :)



More information about the CentOS mailing list