[CentOS] Exim on all interfaces

Morten lists at kikobu.com
Fri Oct 21 17:14:43 UTC 2005


Hi. I have a default installation of Exim with only a few changed 
settings. It appears to only bind to the loopback interface. I have not 
set any local_interfaces values, as the default behaviour is to bind on 
all interfaces. But alas, exim does not respond on its IP address:

[root at obiwan ~]# /etc/init.d/exim restart
Shutting down exim:                                        [  OK  ]
Starting exim:                                             [  OK  ]
[root at obiwan ~]# ifconfig eth0
eth0      Link encap:Ethernet  HWaddr 00:07:E9:26:FD:29
           inet addr:192.168.0.101  Bcast:192.168.0.255  Mask:255.255.255.0
           inet6 addr: fe80::207:e9ff:fe26:fd29/64 Scope:Link
           UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
           RX packets:49916 errors:0 dropped:0 overruns:0 frame:0
           TX packets:27221 errors:0 dropped:0 overruns:0 carrier:0
           collisions:0 txqueuelen:1000
           RX bytes:7366849 (7.0 MiB)  TX bytes:3741826 (3.5 MiB)
           Base address:0xddc0 Memory:fe9e0000-fea00000

[root at obiwan ~]# telnet 192.168.0.101 25
Trying 192.168.0.101...
telnet: connect to address 192.168.0.101: Connection refused
telnet: Unable to connect to remote host: Connection refused
[root at obiwan ~]# telnet 127.0.0.1 25
Trying 127.0.0.1...
Connected to obiwan (127.0.0.1).
Escape character is '^]'.
220 obiwan ESMTP Sendmail 8.13.1/8.13.1; Fri, 21 Oct 2005 19:08:25 +0200

I've tried to explicitly set local_interfaces to 127.0.0.1 : 
192.168.0.101 but no such luck.

Any clues?

Thanks.

Morten






More information about the CentOS mailing list