[CentOS] Opteron + Nvidia + Centos 4.2 i386 = Thud

Jake Grimmett jake.grimmett at nimr.mrc.ac.uk
Thu Oct 27 14:02:16 UTC 2005


Dear All,

Just returned from vacation and was delighted to see that Centos 4.2 is now on 
the mirrors. Unfortunately the new i386 version is giving us problems on our 
dual Opteron workstations with Nvidia graphics cards...

Basically, nine times out of ten, the boxes will hang when they try to re-load 
X...  and just sit there with the keyboards Caps and Scroll lock LED's 
flashing. The only way out is the reset button.

The working fixes I have so far found are to either use a non-smp kernel 
(2.6.9-22.EL) or to use the VESA X driver. Neither is a proper solution as 
the machines are used for 3D modeling.

Non working fix attempts have included:
passing acpi=off to the kernel
trying Nvidia driver versions x86-1.0-7676, x86-1.0-7667 and x86-1.0-6629
Installing Centos from scratch as well as upgrading Centos 4.1 to 4.2 (via 
up2date) 
Trying three different Nvidia cards (Geforce 6800U, 5900 and a MX200) 
Trying two different motherboards (Tyan thunder K8W and Tiger K8W - both are 
AMD 8000 chipset based) 
Trying two different pairs of Opteron 240's and Opteron 246's.

As things used to work more or less perfectly with i386 Centos 4.1 
(2.6.9-11.ELsmp and the Nvidia 7667 driver) I'm starting to feel a little 
stupid - any chance that someone could put me out of my misery and suggest 
some solutions? 

Many thanks

Jake
-- 
Dr J. Grimmett
Computer Systems Manager
Division of Molecular Structure
National Institute for Medical Research
The Ridgeway
Mill Hill
London, NW7 1AA
Tel: 0208 816 2028
Fax: 0208 906 4477



More information about the CentOS mailing list