[CentOS] YUM error - are repositories down or something?

Ignacio Vazquez-Abrams ivazquez at ivazquez.net
Mon Sep 19 10:09:30 UTC 2005


On Mon, 2005-09-19 at 18:51 +0900, Dave Gutteridge wrote:
> Following advice on how to ensure that PHP and MySQL are on my machine
> and working correctly, I ran the following YUM command, with the
> subsequent error:
> 
> [root at localhost ~]# yum install php php-mysql httpd mysqlclient10 mysql-
> server
> Setting up Install Process
> Setting up Repos
> http://apt.sw.be/redhat/el4/en/i386/dag/repodata/repomd.xml: [Errno 4]
> IOError: <urlopen error (113, 'No route to host')>
> Trying other mirror.
> Cannot open/read repomd.xml file for repository: dag
> failure: repodata/repomd.xml from dag: [Errno 256] No more mirrors to
> try.
> 
> Unless I am misunderstanding this error (which is quite likely), it
> seems to indicate that YUM can not reach the online repositories. Is
> that the case?
> 
> Or does the problem reside on my end?

It means that yum can't reach the machine that hosts the dag repo. Where
the blame should be laid for this is a different issue. traceroute
should be able to help you diagnose it.

-- 
Ignacio Vazquez-Abrams <ivazquez at ivazquez.net>
http://centos.ivazquez.net/

gpg --keyserver hkp://subkeys.pgp.net --recv-key 38028b72
-------------- next part --------------
A non-text attachment was scrubbed...
Name: not available
Type: application/pgp-signature
Size: 189 bytes
Desc: This is a digitally signed message part
Url : http://lists.centos.org/pipermail/centos/attachments/20050919/0bdc1c0c/attachment.bin


More information about the CentOS mailing list