[CentOS] CentOS4 and Apache-DBI

David Hiltz dhiltz at whsun1.wh.whoi.edu
Tue Sep 20 15:21:02 UTC 2005


Has anybody gotten Apache-DBI to work under CentOS4?


My installed rpms are:

   httpd-2.0.52-12.1.ent.centos4      (came with CentOS4)

   mod_perl-1.99_16-4.centos4         (came with CentOS4)

   perl-Apache-DBI-0.94-1.2.el4.rf    (from Dag's site)
      --this includes Apache::DBI and Apache::AuthDBI

 In my '/etc/httpd/conf/httpd.conf' file, I added:

 PerlModule Apache::DBI
 PerlModule Apache::AuthDBI


  ..but when I restart Apache I get:

-----------------------------------------------------------------------------
Can't locate Apache/Constants.pm in @INC...
...
BEGIN failed--compilation aborted at 
/usr/lib/perl5/vendor_perl/5.8.5/Apache/AuthDBI.pm line 21.
...
Can't load Perl module Apache::AuthDBI
-----------------------------------------------------------------------------

I read that there is a conflict between Apache2 (httpd-2.0.52-12.1) and 
mod_perl which v1.99 (still pre-v2).   

------------------------------------------------------------------------------
Any help would be greatly appreciated.

----
David Hiltz
dhiltz at whsun1.wh.whoi.edu







More information about the CentOS mailing list