[CentOS] Missing Dependency problem while upgraing a pure (?) whitebox 4 install to Centos 4.2

Sanjay Arora sanjay.k.arora at gmail.com
Wed Mar 15 20:08:49 UTC 2006


Hi all

I don't have the full Centos 4 CD distro, only the minimal server one
(single CD). I use whitebox 4 for desktop installs and then change the
necessary files whitebox-release, diskdumputils, yum etc. & change it
to centos...never had a problem.

This time however, I don't know why, but I chose the "Everything"
option in the package selection dialog during install. Post
installation, I changed the server to centos, by changing the
appropriate files & installed postgreSQL 8.1 from local HDD using yum
localinstall option...it installed perfectly.

Then I gave a yum -y update command & went to sleep...& found the
errors below in the morning. I agree that it is not a centos
problem...but whitebox too is a RHEL derived OS and quite strict about
remaining with the upstream.

One doubt I have is that maybe I'm mistaken & the fresh install was
not a fresh install after all (done in the middle of night with
drooping eyes)...the earlier install on this system was centos 4.2
with centos extras & dag repo enabled and I may have chosen not to
format the system & keep data or maybe the upgrade method.

Can someone look at the files below & tell me these are from out of
centos 4.2 repo and confirm the above doubt (another prob is that the
rpm database should have been recreated on fresh install & there
should be an upgrade log file in my root from anaconda...not there)

Comments? Also, how do I downgrade packages using yum to get out of
this dependency hell? Can I do it with one yum command or do I have to
uninstall packages creating problems one by one?

Sanjay.
Error: Missing Dependency: gcc = 3.4.3-9.EL4 is needed by package gcc-g77
Error: Missing Dependency: php = 4.3.9-3.2 is needed by package php-domxml
Error: Missing Dependency: gcc4 = 4.0.0-0.14.EL4 is needed by package
gcc4-gfortran
Error: Missing Dependency: php = 4.3.9-3.2 is needed by package php-xmlrpc
Error: Missing Dependency: cyrus-imapd = 2.2.10-1.RHEL4.1 is needed by
package cyrus-imapd-devel
Error: Missing Dependency: rpm = 4.3.3-7_nonptl.WB2 is needed by
package rpm-devel
Error: Missing Dependency: gcc = 3.4.3-9.EL4 is needed by package gcc-gnat
Error: Missing Dependency: gcc = 3.4.3-9.EL4 is needed by package gcc-objc
Error: Missing Dependency: libc-client = 2002e-8 is needed by package
libc-client-devel
Error: Missing Dependency: php = 4.3.9-3.2 is needed by package php-ncurses
Error: Missing Dependency: kdegraphics = 7:3.3.1-3.3 is needed by
package kdegraphics-devel
Error: Missing Dependency: gtkhtml3 = 3.3.2-3 is needed by package
gtkhtml3-devel
Error: Missing Dependency: php = 4.3.9-3.2 is needed by package php-pear
Error: Missing Dependency: ruby-libs = 1.8.1-7.EL4.0 is needed by
package ruby-devel
Error: Missing Dependency: iiimf-libs = 1:12.1-10.EL is needed by
package iiimf-libs-devel
Error: Missing Dependency: glibc-devel = 2.3.4-2 is needed by package nptl-devel
Error: Missing Dependency: gcc4 = 4.0.0-0.14.EL4 is needed by package gcc4-c++
Error: Missing Dependency: freeradius = 1.0.1-2.RHEL4 is needed by
package freeradius-postgresql
Error: Missing Dependency: php = 4.3.9-3.2 is needed by package php-gd
Error: python-devel conflicts with python < 2.3.4-14.2
Error: Missing Dependency: php = 4.3.9-3.2 is needed by package php-odbc
Error: Missing Dependency: openoffice.org = 1.1.2-24.6.0.EL4 is needed
by package openoffice.org-i18n
Error: Missing Dependency: openldap-servers = 2.2.13-2 is needed by
package openldap-servers-sql
Error: Missing Dependency: lockdev = 1.0.1-3 is needed by package lockdev-devel
Error: Missing Dependency: rpm = 4.3.3-7_nonptl.WB2 is needed by
package rpm-build
Error: Missing Dependency: java-1.4.2-gcj-compat = 0:1.4.2.0-26jpp is
needed by package java-1.4.2-gcj-compat-devel
Error: Missing Dependency: php = 4.3.9-3.2 is needed by package php-devel
Error: Missing Dependency: gcc4 = 4.0.0-0.14.EL4 is needed by package
libmudflap-devel
Error: Missing Dependency: gcc = 3.4.3-9.EL4 is needed by package gcc-c++
Error: Missing Dependency: php = 4.3.9-3.2 is needed by package php-mbstring
Error: Missing Dependency: oprofile = 0.8.1-11 is needed by package
oprofile-devel
Error: Missing Dependency: php = 4.3.9-3.2 is needed by package php-pgsql



More information about the CentOS mailing list