[CentOS] Yum error - dependency spamassassin-tools

Adriano Frare alfrare at e-alinux.com
Thu Mar 16 18:49:07 UTC 2006


Dear Friends,

I executed yum upgrade and yum show that there is dependency 
spamassassin-tools, but I have installed.

See LOG YUM

[root at srv001 qmailscan]# yum update
Setting up Update Process
Setting up repositories
kbs-CentOS-Extras         100% |=========================|  951 B    00:00
update                    100% |=========================|  951 B    00:00
dag                       100% |=========================| 1.1 kB    00:00
base                      100% |=========================| 1.1 kB    00:00
addons                    100% |=========================|  951 B    00:00
extras                    100% |=========================| 1.1 kB    00:00
Reading repository metadata in from local files
primary.xml.gz            100% |=========================|  75 kB    00:07
update    : ################################################## 186/186
Added 1 new packages, deleted 0 old in 0.53 seconds
primary.xml.gz            100% |=========================| 1.3 MB    02:17
dag       : ################################################## 3832/3832
Added 0 new packages, deleted 0 old in 22.71 seconds
Resolving Dependencies
--> Populating transaction set with selected packages. Please wait.
---> Package kernel-devel.i686 0:2.6.9-34.EL set to be installed
---> Package mailman.i386 3:2.1.5.1-34.rhel4.2 set to be updated
---> Package python.i386 0:2.3.4-14.2 set to be updated
---> Package spamassassin.i386 0:3.0.5-3.el4 set to be updated
---> Package kdegraphics-devel.i386 7:3.3.1-3.9 set to be updated
---> Package initscripts.i386 0:7.93.24.EL-1.1.centos4 set to be updated
---> Package kernel.i686 0:2.6.9-34.EL set to be installed
---> Package python-docs.i386 0:2.3.4-14.2 set to be updated
---> Package kernel-doc.noarch 0:2.6.9-34.EL set to be updated
---> Package openssh-server.i386 0:3.9p1-8.RHEL4.12 set to be updated
---> Package squid.i386 7:2.5.STABLE6-3.4E.12 set to be updated
---> Package tkinter.i386 0:2.3.4-14.2 set to be updated
---> Package openssh-clients.i386 0:3.9p1-8.RHEL4.12 set to be updated
---> Package audit-libs.i386 0:1.0.12-1.EL4 set to be updated
---> Package audit.i386 0:1.0.12-1.EL4 set to be updated
---> Package audit-libs-devel.i386 0:1.0.12-1.EL4 set to be updated
---> Package kdegraphics.i386 7:3.3.1-3.9 set to be updated
---> Package python-tools.i386 0:2.3.4-14.2 set to be updated
---> Package rsync.i386 0:2.6.7-1.2.el4.rf set to be updated
---> Package python-devel.i386 0:2.3.4-14.2 set to be updated
---> Package openssh-askpass.i386 0:3.9p1-8.RHEL4.12 set to be updated
---> Package openssh-askpass-gnome.i386 0:3.9p1-8.RHEL4.12 set to be updated
---> Package openssh.i386 0:3.9p1-8.RHEL4.12 set to be updated
---> Downloading header for gnupg to pack into transaction set.
gnupg-1.2.6-3.i386.rpm    100% |=========================|  15 kB    00:00
---> Package gnupg.i386 0:1.2.6-3 set to be updated
--> Running transaction check
--> Processing Dependency: perl(Mail::SpamAssassin) = 3.0.4 for package: 
spamassassin-tools
--> Finished Dependency Resolution
Error: Missing Dependency: perl(Mail::SpamAssassin) = 3.0.4 is needed by 
package spamassassin-tools



Thanks

Adriano




More information about the CentOS mailing list