[CentOS] rpmbuild

James B. Byrne ByrneJB at Harte-Lyne.ca
Wed Mar 22 20:52:43 UTC 2006


So, after a quick rush through the documentation and modifying the 
spec file to show version: 1.3.0 and release: centos4.2 I tried to 
build the subversion package using:


> rpmbuild -ba subversion.spec

and I got this:


> error: Failed build dependencies:
>         apr-devel >= 0.9.5 is needed by
>         subversion-1.3.0-centos4.2.i386 apr-util-devel >= 0.9.5 is
>         needed by subversion-1.3.0-centos4.2.i386

So, since this software is working on my system and since centos 
seems to backport the essentials I made the leap that apr-0.9.4 was 
good enough.  I went in and altered the spec file again to set the 
minimum version of apr down to 0.9.5. Now I get:

> rpmbuild -ba subversion.spec

> ...
> configure: Apache Portable Runtime (APR) library configuration
> checking for APR... yes
> checking APR version... 0.9.4
> wanted regex is 0\.9\.[5-9] or 1\.
> configure: error: invalid apr version found
> error: Bad exit status from /var/tmp/rpm-tmp.51580 (%prep)

So, I was wrong.  Is there some easy way to fix this short of 
installing apr-0.9.5 over 0.9.4?

Digest subscriber, direct copies of any replies appreciated.

Regards,
Jim
--   
     *** e-mail is not a secure channel ***
mailto:byrnejb.<token>@harte-lyne.ca
James B. Byrne                Harte & Lyne Limited
vox: +1 905 561 1241          9 Brockley Drive
fax: +1 905 561 0757          Hamilton, Ontario
<token> = hal                 Canada L8E 3C3




More information about the CentOS mailing list