[CentOS] CentOS 3 and openswan > 2.2.1

Nicole Haehnel nicole.haehnel at web.de
Mon Mar 27 11:47:13 UTC 2006


Hi,

is there anybody  running centos3 (el3) with a standard kernel 2.4.32 or 
newer, because it seems openswan versions > 2.21 don't run with 
centos3(el3) anymore.
But we need the newer openswan versions.

Problem arise when I try to build the ipsec.o module:
 /usr/src/openswan-2.4.4/linux/net/ipsec/ipsec_init.c
/usr/src/openswan-2.4.4/linux/net/ipsec/ipsec_init.c: In function 
`openswan_inet_add_protocol':
/usr/src/openswan-2.4.4/linux/net/ipsec/ipsec_init.c:162: too few 
arguments to function `inet_add_protocol_Rsmp_dc5483d7'
/usr/src/openswan-2.4.4/linux/net/ipsec/ipsec_init.c: In function 
`openswan_inet_del_protocol':
/usr/src/openswan-2.4.4/linux/net/ipsec/ipsec_init.c:169: too few 
arguments to function `inet_del_protocol_Rsmp_23842692'   

If I use a vanilla kernel, some other things break like iptables...

Maybe a spec file for a vanilla kernel + iptables?

Anybody can help?

Thanks!

Nicole




More information about the CentOS mailing list