[CentOS] ATI Radeon Mobility M6 LY & IBM Thinkpad R40

Max btmanmeh at verizon.net
Tue Mar 28 16:10:57 UTC 2006


Does anyone have any experience with the combination of a Thinkpad R40 
and the ATI Radeon Mobility M6 LY video chip? I've had CentOS 4.1, 4.2, 
and now 4.3 running just great with 1024x768 resolution, but according 
the IBM specs, this chip is capable of 1280x1024.

A quick lspci -v | grep ATI spewed the following:

01:00.0 VGA compatible controller: ATI Technologies Inc Radeon Mobility 
M6 LY (prog-if 00 [VGA])

I can successfully change the settings under the display menu to 
1280x1024, but upon restarting X the default greeter crashes. After 
that, it picks another greeter and allows me to log in, with it still 
picking 1024x768. I've played around with trying to manually change the 
settings in /etc/X11/xorg.conf file. I've tried various depth settings 
to no avail.

The section identifying the card in xorg.conf is:

Section "Device"
         Identifier  "Videocard0"
         Driver      "radeon"
         VendorName  "Videocard vendor"
         BoardName   "ATI Radeon Mobility M6"
EndSection

According to what I've been reading, that's what is supposed to be 
there. I've found a few things stating that DRI could be a problem, but 
I'm not too familiar with this.

Also, a friend has an R40 but has the ATI Mobility Radeon 7500 chip, 
instead of the M6 like mine. He's also running CentOS 4.3 and having the 
exact same problem I'm having. Same deal, according to the IBM specs his 
chipset as well as mine should be capable of 1280x1024. Any thoughts or 
related experience with this? If not, it's not a huge deal, I've been 
using it 1024x768 for well over a year now, but the extra resolution 
would be wonderful. Thanks!

Max





More information about the CentOS mailing list