[CentOS] Dependency failures when updating

Tom Elsesser tom at acalprecision.com
Fri Sep 1 12:32:32 UTC 2006


I am trying to update a centos box with an unsupported kernel (for XFS 
support):

[root at snowybunting /]# uname -a
Linux snowybunting.homelinux.net 2.6.9-34.106.unsupportedsmp #1 SMP Sat 
Mar 18 16:22:41 CST 2006 x86_64 x86_64 x86_64 GNU/Linux

To update I did:

yum update python-sqlite
yum clean all
yum update yum
yum clean all
yum update

..and I get the following

> 91 packages excluded due to repository protection

<bunch of stuff deleted>

> --> Running transaction check
> --> Processing Dependency: kernel-ib for package: libibverbs
> --> Processing Dependency: kernel-ib for package: libsdp
> --> Processing Dependency: kernel-ib for package: dapl
> --> Processing Dependency: kernel-ib for package: libmthca
> --> Processing Dependency: kernel-ib for package: librdmacm
> --> Finished Dependency Resolution
> Error: Missing Dependency: kernel-ib is needed by package libibverbs
 > Error: Missing Dependency: kernel-ib is needed by package libsdp
 > Error: Missing Dependency: kernel-ib is needed by package dapl
 > Error: Missing Dependency: kernel-ib is needed by package libmthca
 > Error: Missing Dependency: kernel-ib is needed by package librdmacm

I unprotected the repositories in /etc/yum.repo.d, then reran:

yum update

...and I get the same missing dependencies errors. I don't know if I 
have too many things going on at once with the unsupported kernel and 
updating the whole base, but as of now I'm kind of stuck. Any thoughts?

-- 
Tom Elsesser



More information about the CentOS mailing list