[CentOS] Jpackage tomcat55-common-lib requires eclipse-ecj >= 0:3.1.1

Will McDonald wmcdonald at gmail.com
Wed Sep 27 12:09:49 UTC 2006


Guys,

I'm running into a dependecy issue running through the process of
building a system for Openbravo. My test system's running CentOS 4.4,
i386.

Openbravo requires...

- Jakarta-Tomcat version 5.5. It can be downloaded from
http://tomcat.apache.org/
- Java (TM) 2 Platform Standard Edition 5.0. It can be downloaded from
http://java.sun.com/j2se/1.5.0/download.jsp
- Oracle(r) 10g database release 2. It can be downloaded from
http://www.oracle.com
- Apache-ant 1.6. It can be downloaded from http://ant.apache.org/

So far (see attached text file for rough documentation of build
sequence) I've built Java and JTA successfully. When I try to install
tomcat55 it results in...

"Error: Missing Dependency: eclipse-ecj >= 0:3.1.1 is needed by
package tomcat55-common-lib"

Jpackage 1.6 only has eclipse-3.0.2 as far as I can see. So, my
question, is there a preferred or authoratative source for
packaging/or a prepackaged Eclipse that'll fulfil my requirements?

I've searched around and found mention of Jason Corley 's SRPMs
http://www.zarb.org/~jasonc/repo/ from
https://www.zarb.org/pipermail/jpackage-discuss/2006-June/010098.html,
I'll have a play with those now.

Do I need to switch to 1.7 to fulfil these requirements? Any
suggestions or best-practices greatfully received.

Cheers,

Will
-------------- next part --------------
# yum install rpm-build
# cd /etc/yum.repos.d/
# wget http://www.jpackage.org/jpackage.repo

Edit /etc/yum.repos.d/jpackage.repo and enable=1 [jpackage-rhel] and [jpackage-generic-nonfree]

# yum -y install jpackage-utils
# su - wmcdonald
$ mkdir -p rpm/{BUILD,RPMS/{i386,i586,noarch},SOURCES,SPECS,SRPMS,tmp}

Edit ~/.rpmmacros and add...

	%_topdir        %(echo ${HOME}/rpm)
	%_tmppath       %{_topdir}/tmp
	%packager       Will Mc Donald <wmcdonald at gmail.com>


$ cd rpm/RPMS/noarch/
$ wget http://mirrors.dotsrc.org/jpackage/1.6/generic/non-free/SRPMS/java-1.5.0-sun-1.5.0.07-1jpp.nosrc.rpm
$ wget http://mirrors.dotsrc.org/jpackage/1.6/generic/non-free/SRPMS/jta-1.0.1-0.b.4jpp.nosrc.rpm
$ rpm -ivh java-1.5.0-sun-1.5.0.07-1jpp.nosrc.rpm jta-1.0.1-0.b.4jpp.nosrc.rpm
$ cd ~/rpm/SOURCES/

Go to http://java.sun.com/products/archive/j2se/5.0_07/index.html then Download JDK, Accept License Agreement, then download: jdk-1_5_0_07-linux-i586.bin
Either download manually then copy into ~/rpm/SOURCES/ or copy the link once you've agreed to the license for jdk-1_5_0_07-linux-i586.bin and then replace $LINK...

$ lftpget $LINK

Go to http://java.sun.com/products/jta/ then download jta-1_0_1B-classes.zip (Class Files 1.0.1B) and jta-1_0_1B-doc.zip (JavaDocs 1.0.1B). For each download again either download manually and copy to ~/rpm/SOURCES/ or copy the $LINK and then

$ lftpget $LINK

$ cd ~
$ rpmbuild -ba ~/rpm/SPECS/java-1.5.0-sun.spec
$ rpmbuild -ba ~/rpm/SPECS/jta.spec
This should scroll a bunch of stuff up the screen ending with...

Wrote: /home/wmcdonald/rpm/SRPMS/java-1.5.0-sun-1.5.0.07-1jpp.nosrc.rpm
Wrote: /home/wmcdonald/rpm/RPMS/i586/java-1.5.0-sun-1.5.0.07-1jpp.i586.rpm
Wrote: /home/wmcdonald/rpm/RPMS/i586/java-1.5.0-sun-devel-1.5.0.07-1jpp.i586.rpm
Wrote: /home/wmcdonald/rpm/RPMS/i586/java-1.5.0-sun-src-1.5.0.07-1jpp.i586.rpm
Wrote: /home/wmcdonald/rpm/RPMS/i586/java-1.5.0-sun-demo-1.5.0.07-1jpp.i586.rpm
Wrote: /home/wmcdonald/rpm/RPMS/i586/java-1.5.0-sun-plugin-1.5.0.07-1jpp.i586.rpm
Wrote: /home/wmcdonald/rpm/RPMS/i586/java-1.5.0-sun-fonts-1.5.0.07-1jpp.i586.rpm
Wrote: /home/wmcdonald/rpm/RPMS/i586/java-1.5.0-sun-alsa-1.5.0.07-1jpp.i586.rpm
Wrote: /home/wmcdonald/rpm/RPMS/i586/java-1.5.0-sun-jdbc-1.5.0.07-1jpp.i586.rpm
Executing(%clean): /bin/sh -e /home/wmcdonald/rpm/tmp/rpm-tmp.86010
+ umask 022
+ cd /home/wmcdonald/rpm/BUILD
+ cd jdk1.5.0_07
+ rm -rf /home/wmcdonald/rpm/tmp/java-1.5.0-sun-1.5.0.07-1jpp-buildroot
+ exit 0

$ cd ~
$ rpmbuild -ba ~/rpm/SPECS/jta.spec

This should scroll a bunch of stuff up the screen ending with...

$ logout
# yum install unixODBC-devel
# cd /home/wmcdonald/rpm/RPMS/i586/
# rpm -ivh java-1.5.0-sun-1.5.0.07-1jpp.i586.rpm java-1.5.0-sun-alsa-1.5.0.07-1jpp.i586.rpm java-1.5.0-sun-demo-1.5.0.07-1jpp.i586.rpm java-1.5.0-sun-devel-1.5.0.07-1jpp.i586.rpm java-1.5.0-sun-fonts-1.5.0.07-1jpp.i586.rpm java-1.5.0-sun-jdbc-1.5.0.07-1jpp.i586.rpm java-1.5.0-sun-plugin-1.5.0.07-1jpp.i586.rpm


# su - wmcdonald
$ cd ~
$ rpmbuild -ba ~/rpm/SPECS/jta.spec

This should scroll a bunch of stuff up the screen ending with...

Wrote: /home/wmcdonald/rpm/SRPMS/jta-1.0.1-0.b.4jpp.nosrc.rpm
Wrote: /home/wmcdonald/rpm/RPMS/noarch/jta-1.0.1-0.b.4jpp.noarch.rpm
Wrote: /home/wmcdonald/rpm/RPMS/noarch/jta-javadoc-1.0.1-0.b.4jpp.noarch.rpm
Executing(%clean): /bin/sh -e /home/wmcdonald/rpm/tmp/rpm-tmp.89566
+ umask 022
+ cd /home/wmcdonald/rpm/BUILD
+ cd jta-1.0.1
+ rm -rf /home/wmcdonald/rpm/tmp/jta-1.0.1-0.b.4jpp-buildroot
+ exit 0


$ logout
# cd /home/wmcdonald/rpm/RPMS/i586/
# rpm -ivh jta-1.0.1-0.b.4jpp.noarch.rpm jta-javadoc-1.0.1-0.b.4jpp.noarch.rpm
# yum install eclipse-ecj




More information about the CentOS mailing list