[CentOS] possible corrupt rpm database

Dave dmehler26 at woh.rr.com
Mon Jul 23 22:20:48 UTC 2007


Hello,
    I've got a centos5 box that at least has a dependency issue or a corrupt 
rpm database. I am open to suggestions as to how to proceed. I have added 
some extra repositories to my yum configuration, centosplus, rpmforge, 
atrpms, and the kbs repos. I haven't been having issues with installs or 
upgrades until today when i ran a yum update, and got a missing dependency 
error for zaptel, a perl dependency. I've tried doing a yum install for the 
package, but no success. The error is below and i am open to suggestions.
Thanks.
Dave.

#yum update
Loading "installonlyn" plugin
Setting up Update Process
Setting up repositories
Reading repository metadata in from local files
Excluding Packages from CentOS-5 - Base
Finished
Excluding Packages from CentOS-5 - Updates
Finished
Resolving Dependencies
--> Populating transaction set with selected packages. Please wait.
---> Package asterisk-devel.i386 1:1.4.8-42.el5 set to be updated
---> Package zaptel.i386 1:1.4.4-36.el5 set to be updated
---> Package asterisk.i386 1:1.4.8-42.el5 set to be updated
--> Running transaction check
--> Processing Dependency: perl(Zaptel::Config::Defaults) for package: 
zaptel
--> Finished Dependency Resolution
Error: Missing Dependency: perl(Zaptel::Config::Defaults) is needed by 
package zaptel




More information about the CentOS mailing list