[CentOS] Re: possible corrupt rpm database

Axel Thimm Axel.Thimm at ATrpms.net
Tue Jul 24 14:11:55 UTC 2007


On Tue, Jul 24, 2007 at 04:02:59PM +0200, Axel Thimm wrote:
> On Mon, Jul 23, 2007 at 04:48:32PM -0600, Grant McChesney wrote:
> > On 7/23/07, Dave <dmehler26 at woh.rr.com> wrote:
> > >--> Processing Dependency: perl(Zaptel::Config::Defaults) for package:
> > >zaptel
> > >--> Finished Dependency Resolution
> > >Error: Missing Dependency: perl(Zaptel::Config::Defaults) is needed by
> > >package zaptel
> 
> > This is a dependency problem with ATrpms repo--not CentOS.  I suggest
> > subscribing to the ATrpms users list at
> > atrpms-users at atrpms.net<../mail?view=cm&tf=0&to=atrpms-users at atrpms.net>or
> > following this thread in the archives:
> > http://lists.atrpms.net/pipermail/atrpms-users/2007-July/007568.html
> 
> I can confirm this to be a bug in the package (looks like an upstream
> bug, but still a bug in the package), will be fixed within a couple of
> hours.

Here's the fix, or you can wait ~1h for new packages to appear in the
repo:

--- zaptel-1.4.4/xpp/utils/Makefile~    2007-07-13 10:22:28.000000000 +0200
+++ zaptel-1.4.4/xpp/utils/Makefile     2007-07-24 16:06:58.000000000 +0200
@@ -24,7 +24,7 @@
 HOTPLUG_USB_DIR        = /etc/hotplug/usb
 UDEV_RULES_DIR = /etc/udev/rules.d
 PERLLIBDIR     = $(shell eval `perl -V:sitelib`; echo "$$sitelib")
-PERL_DIRS      := Zaptel Zaptel/Hardware Zaptel/Xpp
+PERL_DIRS      := Zaptel Zaptel/Config Zaptel/Hardware Zaptel/Xpp
 PERL_MODS_PAT  := *.pm $(PERL_DIRS:%=%/*.pm)
 PERL_MODS      := $(shell cd zconf; echo $(PERL_MODS_PAT))
-- 
Axel.Thimm at ATrpms.net
-------------- next part --------------
A non-text attachment was scrubbed...
Name: not available
Type: application/pgp-signature
Size: 189 bytes
Desc: not available
Url : http://lists.centos.org/pipermail/centos/attachments/20070724/78f0cb54/attachment.bin


More information about the CentOS mailing list