[CentOS] data corruption on AMD AM2 systems with 4GB of RAM or more

Feizhou feizhou at graffiti.net
Fri Jun 1 02:33:50 UTC 2007


Bart Schaefer wrote:
> On 5/30/07, Feizhou <feizhou at graffiti.net> wrote:
>> Bart Schaefer wrote:
>> > We have not tried building a kernel, nor installing any drivers or
>> > other kernel-related software other than that available from the
>> > CentOS project repos.  However, the machine is fully yum-updated.
>>
>> So you also do not have the IOMMU enabled in your boxes?
> 
> % dmesg | grep -i iommu
> Please enable the IOMMU option in the BIOS setup
> PCI-DMA: using GART IOMMU.
> PCI-DMA: Reserving 64MB of IOMMU area in the AGP aperture

Try building a 2.6.21 kernel and see if your problems go away.



More information about the CentOS mailing list