[CentOS] yum update failure, dependancy issues for yum

Devraj Mukherjee devraj at gmail.com
Fri Jun 1 03:30:05 UTC 2007


Hi everyone,

My CentOS 4.4 machine refuses to yum update. Here is the output, any
pointers as to what I can do?

Thanks

[root at monk ~]# yum update
Setting up Update Process
Setting up repositories
atrpms                    100% |=========================|  951 B    00:00
update                    100% |=========================|  951 B    00:00
base                      100% |=========================| 1.1 kB    00:00
addons                    100% |=========================|  951 B    00:00
extras                    100% |=========================| 1.1 kB    00:00
Reading repository metadata in from local files
primary.xml.gz            100% |=========================| 295 kB    00:02
################################################## 1393/1393
primary.xml.gz            100% |=========================|  34 kB    00:00
################################################## 127/127
Resolving Dependencies
--> Populating transaction set with selected packages. Please wait.
---> Downloading header for file to pack into transaction set.
file-4.10-3.0.2.el4.i386. 100% |=========================| 9.8 kB    00:00
---> Package file.i386 0:4.10-3.0.2.el4 set to be updated
---> Downloading header for up2date to pack into transaction set.
up2date-4.5.5-6.el4.cento 100% |=========================|  45 kB    00:00
---> Package up2date.i386 0:4.5.5-6.el4.centos set to be updated
---> Package yum-utils.noarch 0:0.5-2.el4.centos set to be updated
--> Running transaction check
--> Processing Dependency: yum < 2.5 for package: yum-utils
--> Restarting Dependency Resolution with new changes.
--> Populating transaction set with selected packages. Please wait.
---> Package yum.noarch 0:2.4.3-3.el4.centos set to be updated
--> Running transaction check
--> Processing Dependency: yum >= 2.6.2 for package: yum-metadata-parser
--> Finished Dependency Resolution
Error: Missing Dependency: yum >= 2.6.2 is needed by package yum-metadata-parser


-- 
"I never look back darling, it distracts from the now", Edna Mode (The
Incredibles)



More information about the CentOS mailing list