[CentOS] Re: Madwifi just seems to work in Centos 5

Axel Thimm Axel.Thimm at ATrpms.net
Mon Jun 18 16:25:33 UTC 2007


On Mon, Jun 18, 2007 at 12:22:04PM -0400, Robert Moskowitz wrote:
> 
> Axel Thimm wrote:
> 
> >On Mon, Jun 18, 2007 at 11:55:25AM -0400, Robert Moskowitz wrote:
> >  
> >>>>>On Mon, Jun 18, 2007 at 08:03:39AM -0400, Robert Moskowitz wrote:
> >>>>>          
> >>>>>>I have not installed the madwifi specific kernel stuff (kdml and
> >>>>>>hal-kdml) from atrpms.  I have installed with wpa rpms.
> >>>>>>
> >>>>>>And my Atheros card is working with almost no work on my part (other
> >>>>>>than runing wpa_supplicant as a deamon).
> >>>>>>            
> >
> >  
> >>Here is the results from lspci and lsmod.  There is ONE madwifi rpm 
> >>installed:
> >>
> >>madwifi-0.9.2.1-2.el5.rf.i386.rpm
> >>    
> >
> >  
> >>ath_pci                86180  0 
> >>ath_rate_sample        16896  1 ath_pci
> >>wlan                  172764  4 wlan_scan_sta,ath_pci,ath_rate_sample
> >>ath_hal               195280  3 ath_pci,ath_rate_sample
> >>    
> >
> >So you are obviously using madwifi after all to drive the card. :)
> 
> But where did it come from?????
> 
> I did not install the kernel driver rpms.

madwifi-0.9.2.1-2.el5.rf.i386.rpm follows a different method that
creates them on your system. There are pros and cons to using prebuilt
binaries vs your own custom kernel modules.
-- 
Axel.Thimm at ATrpms.net
-------------- next part --------------
A non-text attachment was scrubbed...
Name: not available
Type: application/pgp-signature
Size: 189 bytes
Desc: not available
Url : http://lists.centos.org/pipermail/centos/attachments/20070618/357838bd/attachment.bin


More information about the CentOS mailing list