[CentOS] 4.4 on PE6400 - not rebooting ... FINALLY WORKS !

Joe Kazura joe.kazura at unh.edu
Tue Mar 6 16:43:11 UTC 2007


Folks - FYI:

I finally got it to work (at least once)!

     reboot=bios,smp,warm

Since I didn't actually TRY 'reboot=triple',  I, of course, am  
wondering if 'reboot=triple' is synonymous for  
'reboot=bios,smp,warm' ...

Mmmmm - masochism!!!

A co-worker pointed me to this:

     /usr/share/doc/kernel-doc-2.6.9/Documentation/kernel-parameters.txt

Specifically:

    reboot=	[BUGS=IA-32,BUGS=ARM,BUGS=IA-64] Rebooting mode
		Format: <reboot_mode>[,<reboot_mode2>[,...]]
		See arch/*/kernel/reboot.c or arch/*/kernel/process.c

BUT - I don't have either 'reboot.c' or 'process.c' (ARG!)

So ... after a TON of googling I found references to various  
combinations of the three, but not all three together.

It works!!!  FINALLY!!!


-- 
+----------------------------[ Joe.Kazura at UNH.EDU ]---+
| Joe Kazura                                          | Mac OS X ...
| CIS/TCS -- 1 Leavitt Lane    PHONE: +1-603-862-2012 |   Because UNIX
| University of New Hampshire                         |   should be user
| Durham, NH  03824-3512  USA    "docendo discimus"   |   friendly!
|                                                     |
+-----------------[ http://www.unh.edu/tcs/ ]---------+



On Mar 2, 2007, at 7:03 AM, Morten Torstensen wrote:

> Joe Kazura wrote:
>> Well - reboot=bios didn't work ...
>> I'll try 'reboot=triple' when I get a chance.
>
> Speaking of the devil... I've had a mobo where I needed reboot=bios  
> on CentOS 4. Now with RHEL5, that parameter is no longer effective.  
> Seems like YMMV a lot. I will try to remember to keep you updated  
> if I find another solution :)
>
> -- 
>
> //Morten Torstensen





More information about the CentOS mailing list